WordPress.org

Ready to get started?Download WordPress

Forums

Database Upgrade Required: Not Working (WP 2.9) (41 posts)

  1. wpwend42
    Member
    Posted 4 years ago #

    Hello. Longtime (5 years) user of WordPress on all of my domains. I went to upgrade to the new 2.9 version this evening and it worked fine, as always. When complete, a screen told me:

    Database Upgrade Required

    WordPress has been updated! Before we send you on your way, we have to upgrade your database to the newest version.

    The upgrade process may take a little while, so please be patient.

    Upgrade WordPress Database

    When I click on the button, it works for a moment and then sits on a WordPress logo with nothing else. I can now not log into my domain b/c it brings me back to this page!

    How can I rectify this situation?

  2. Truth
    Member
    Posted 4 years ago #

    I have this problem as well. Any solutions yet?

    I got this error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 524288 bytes) in /home2/.../wp-db.php on line 734

  3. keithdsouza
    Member
    Posted 4 years ago #

    @Truth - You might need to increase the memory size in your php.ini file or ask your host to do it.

    You will have to change the value for php_value memory_limit in your php.ini. You can Google for the same to find more info.

    @wpwend42 - You might be facing the same problems as @Truth, however your browser might be setup to not display real errors, try to change that setting. Alternatively, check the error log file of your web server to see if there are any errors.

  4. Truth
    Member
    Posted 4 years ago #

    I just manage to do a rollback. I don't think I'll be doing the upgrade any time soon till someone manage to upgrade it successfully. Seems like there are quite a number of errors around.

    Thanks though!

  5. jalmz
    Member
    Posted 4 years ago #

  6. Joe Streno
    Member
    Posted 4 years ago #

    I tried doing an auto-upgrade and had a database fail with a huge list of errors all which start with "WordPress database error: [MySQL server has gone away]", but at the bottom of the list is the button that says your update was successful. Click on it and it brings you back to the "You must update your database page again.

    I restored back to WP 2.86 and my data was okay. I then did a manual update of 2.9 and I got the same result as the auto-update.

    I looked at my server error log ... OMG .... what a mess! I have t call my ISP to see what they can make of it. I'm reverting back to 2.86 & crossing my fingers.

  7. Truth
    Member
    Posted 4 years ago #

    My host increased the memory limit to 50GB but I still couldn't upgrade my database. Help please? :(

  8. I don't think I'll be doing the upgrade any time soon till someone manage to upgrade it successfully. Seems like there are quite a number of errors around.

    Upgraded 5 this morning without any problems. But then again, my backup safety net is pretty iron clad...

    @Truth, congrats on the rollback, too many users don't keep good backups.

    I think you meant 50MB but let's see if we can do some checking.

    Can you create this short file in your installation?

    <?php
    phpinfo();
    ?>

    Save it as wp-content/phpinfo.php afterwards delete it if you want to.

    Now in your browser load up http://your-blog-url/wp-content/phpinfo.php and look for the line that reads memory_limit. Mine says 64M, yours should read 50M.

    Now check the Mysql version. On that same page look for Client API version which is under the mysql section. If that reads 5.0 something, then we can rule out the mysql version.

    I'm asking this to make sure you can rule out memory limits and mysql version problems.

  9. Matoo
    Member
    Posted 4 years ago #

    I had the exact same problem than wpwend42. I followed jalmz link : http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247.

    My problem was indeed that the Option_Value for the Option_Name db_version was '11548' instead of '12329' (http://codex.wordpress.org/Version_2.9).

    I changed it with phpmyadmin, and I recovered my brand new 2.9 wordpress blog.

  10. Truth
    Member
    Posted 4 years ago #

    Thanks jdembowski for the help!

    I have found a way to upgrade successfully.

    I did a rollback to 2.8.6.
    Deactivate all the plugins.
    Did a automatic upgrade to 2.9.
    This time no database upgrade is required.
    Activate all the plugins again and it's working!

    Thank you :)

  11. wpwend42
    Member
    Posted 4 years ago #

    12329 was the problem! Thanks!

  12. war59312
    Member
    Posted 4 years ago #

    O.K glad to see I was not the only one with this problem.

    Indeed changing the database version allows wp to run fine again. Or appear to?

    Does this break anything. Does the database really need to be upgraded?

  13. shellius
    Member
    Posted 4 years ago #

    This should be fixed and releases should not be released until these bugs have been worked out. I can't access two of my blogs now thanks to this problem and nothing I have found here is working. Why don't you developers stop trying to release new versions so quickly? Just let us bloggers be for awhile, without all these upgrades. We don't need constant upgrades.

    I'm really tired of having to fix problems like this that we should never have to deal with.

  14. jmkprime
    Member
    Posted 4 years ago #

    I had a problem with identical symptoms - the database upgrade would hang after a certain point. I looked into the code and found that it was the function pre_schema_upgrade() that was hanging. Specifically the MySQL statement:

    SELECT o1.option_id FROM $wpdb->options AS o1 JOIN $wpdb->options AS o2 ON o2.option_name = o1.option_name AND o2.option_id > o1.option_id

    (line 1685 of wp-admin/includes/upgrade.php)

    The upgrade code is looking for duplicated entries in the options database table to remove.

    When I ran that request in phpAdmin I got a result with 6 million lines, whereas there were only 400 odd lines with distinct option_name values. I added the work distinct after SELECT on that line forcing it to remove duplicate results. That seemed to work and allowed the upgrade to proceed as usual.

  15. exchangeit
    Member
    Posted 4 years ago #

    For what it's worth, I have been having the same problem as Truth. I am backedup and could rollback but am concerned about my skills not being good enough to do this successfully.

    That said, here's what I'm seeing after I upgraded to 2.9. For social bookmark plugins, when they're activated, I'm getting:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /myblog/public_html/wp-includes/kses.php(413) : runtime-created function on line 1

    When I deactivate this one...
    Social Bookmarks 4.1.3
    http://www.dountsis.com/projects/social-bookmarks/

    or deactivate this one
    Social Bookmarking Reloaded 3.02
    http://www.valent-blog.eu/social-bookmarking-reloaded/

    They both produce the same error when I try to edit one a page.

  16. exchangeit
    Member
    Posted 4 years ago #

    OK.. I fixed it via my hosting company and increasing memory_limit to 128 MB in php.ini

  17. mcintyd1
    Member
    Posted 4 years ago #

    jamlz solution at http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247 fixed this for me. The new db_version is 12329 for WP 2.9. Thanks!

  18. humanbeingblog
    Member
    Posted 4 years ago #

    Thanks--I was panicking and it's now fixed with the change to 12329.

  19. mahmood
    Member
    Posted 4 years ago #

    that does not create the new wp_commentsmeta table in the db though. so you might be looking for trouble in the future!

    I'm wondering if there are any other database changes we can apply manually other than this? My database is around 300MB and no matter what changes I do to the php.ini file, the upgrade process simply times out.

    for those interested, the SQL code you need to run to create the new wp_commentmeta table is:


    CREATE TABLE IF NOT EXISTS
    wp_commentmeta (
    meta_id bigint(20) unsigned NOT NULL auto_increment,
    comment_id bigint(20) unsigned NOT NULL default '0',
    meta_key varchar(255) collate utf8_unicode_ci default NULL,
    meta_value longtext collate utf8_unicode_ci,
    PRIMARY KEY (meta_id),
    KEY comment_id (comment_id),
    KEY meta_key (meta_key)
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci AUTO_INCREMENT=1 ;

    Any others changes to the db please?

    HELP, please!

  20. Lime82
    Member
    Posted 4 years ago #

    I have the same issue...
    When trying to access the wp-admin i get redirected to the 'Database Upgrade Required' page. After clicking the button i get 'Upgrade Complete' and then it just loops back to the 'Database Upgrade Required' page. I.E. I cant access admin.

    I've tried this solution:
    http://www.clickonf5.org/wordpress/solution-database-upgrade-required/2247
    -It did not work, versions checks out in db & version.php

    System Requirements are ok, phpinfo says:
    memory_limit = 512M
    Client API version = 5.1.41

    Any help suggestions?
    Sadly and VERY anoying is that I dont have a backup since before the upgrade...

  21. Bliss7
    Member
    Posted 4 years ago #

    To the WordPress developers:

    Please stop releasing new versions without thorough testing...this is what happens when you keep releasing new versions every couple of months....Geez.

    I am also having a problem auto upgrading...I get the fatal error message and not having enough memory.

    I am holding back on this upgrade until Automatic comes up with a more trouble free version.

    It seems a lot of people are having problems and more will come here reporting problems....in the coming days...the availability of auto upgrade means a lot of people wont backup their database and when they run into problems, it will be HEADACHE.

  22. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    @Bliss7:

    If you're not configured for enough memory, then your server needs to be adjusted to allow you to use more memory.

    Upgrades are memory intensive. This cannot be changed. No amount of "testing" would have helped you, because the problem isn't in WordPress, it's in your server configuration.

    There will be no "fix" for lack of memory. Fix your server configuration.

    More info: http://www.google.com/search?q=php+memory+limit

  23. Bliss7
    Member
    Posted 4 years ago #

    @ Otto,

    Sorry if I sounded annoyed, but:

    1) I never had memory problems for a long time. Is WordPress getting more resource intensive?

    2) It seems memory is not the only problem happening, but database problems as well...I don't fancy rolling back

    3) This problem is being reported in various shapes and forms across the forum now, so I'm not barking in the wind.

    Rgds

  24. john m
    Member
    Posted 4 years ago #

    There will be no "fix" for lack of memory. Fix your server configuration.

    @Otto42 - Your response fails to take into account how people are actually using WordPress. What percentage of folks using WP are doing so on their own server vs some sort of hosted environment? I don't have that kind of control over "my" server; most people don't.

  25. john: usually you have some control even if you don't run your own server; you can try increasing the memory for PHP and WordPress by putting this line in your .htaccess file:

    php_value memory_limit 64M

    or this line near the top of your wp-config.php file:

    define('WP_MEMORY_LIMIT', '64M');

    or in your php.ini:

    memory_limit = 64M;

  26. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    @Otto42 - Your response fails to take into account how people are actually using WordPress. What percentage of folks using WP are doing so on their own server vs some sort of hosted environment? I don't have that kind of control over "my" server; most people don't.

    Then you need to talk to the people who do control your server and ask them how to do it, or if they can do it for you.

  27. evanr76
    Member
    Posted 4 years ago #

    @Otto42,

    Respectfully, it's one thing if the WordPress development team doesn't have enough resources to test all possible upgrade scenarios (for example, low memory limit hosted environments), but to say no amount of testing would have uncovered this is simply false.

  28. gatewayy
    Member
    Posted 4 years ago #

    @jalmz than you for the link, this fixed my issue with he db versions not matching up! :)

  29. tempoky2
    Member
    Posted 4 years ago #

    @Matoo

    thank youuuuu

    i read this topic and Matoo's technic work.

    My site come back
    :)

  30. tempoky2
    Member
    Posted 4 years ago #

    when i was activate plugins
    i get this error:
    ***
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 311296 bytes) /wp-includes/canonical.php on line 277
    ***

    and reurn to change my plugin setting

    http://www.sitename/wp-admin/

    i get same error

    :)))

    i can't access wp-admin
    :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.