WordPress.org

Ready to get started?Download WordPress

Forums

Database setup issue (3 posts)

  1. Meckron
    Member
    Posted 1 year ago #

    Server configuration parameters:

    Server 2008 R2 SP1 running SQL Express R2 SP1
    SQL Server 2012 Native Client installed
    WP 3.4.2 (multisite enabled) with PHP 5.3.13 and 5.4.7
    PHP Manager for IIS 7
    WP database abstraction 1.1.4
    PHP for SQL drivers V2 and V3
    AdventureWorks demo installed for testing SQLSRV driver

    Example site for install procedures: http://wordpress.visitmix.com/development/installing-wordpress-on-sql-server#wordpress

    Loading http://localhost/wordpress generates the usual no wp-config.php file. Enter the information to create the file and hit Submit. At this time, the WP database abstraction kicks in, prompting for the same information, adding a line to select SQL version for database.

    Upon hitting submit from this database connection screen after the request parameters have been entered, Internet Explorer works for a few moments then goes to a blank screen. So far, no errors of any sort have been generated (at least I can't find anything stating there's an issue).

    The only clue I've received so far is in running the AdventureWorks demo. AdventureWorks fails to login to its own database, stating a login failure for the user Administrator. The issue here is that in glancing at the php file, it looks as though it's using Windows Authentication. I receive this login error regardless of the user logged into the system attempting the install.

    Any insight on this configuration to help me get WordPress installed would be appreciated.

  2. ricardusexa
    Member
    Posted 1 year ago #

    - First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

  3. Meckron
    Member
    Posted 1 year ago #

    I'm sure that everything is online as it's my own system, it's not hosted.

    I'm using the built-in wizards to generate the wp-config.php file, so I can't double check the settings in it because it hasn't been created yet. If I do create it manually, I get a 500 error.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.