WordPress.org

Ready to get started?Download WordPress

Forums

database problem, non-funcioning categories, or permalinks (19 posts)

  1. benwoodward
    Member
    Posted 8 years ago #

    ok. i have searched the forums and i can't find what i'm looking for. could someone have a look at this and tell me what's wrong - http://www.benwoodward.net

    if you click on post titles it just loads all the posts, as does categories and archives.

    i am no coder, but i am aware that it could be something to do with .htaccess file?

    i think the server is apache, but i'm not sure what version.

    are there any servers that set up wordpress for you so i don't have to deal with all these tech issues?

    many thanks
    ben.

  2. skippy
    Member
    Posted 8 years ago #

    If you suspect .htaccess as a problem, then try deleting that file. Does that change the behavior?

    Have you activated any plugins? If so, try de-activating them. Does that change anything?

    WordPress maintains a small list of hosting providers.

  3. benwoodward
    Member
    Posted 8 years ago #

    for some reason i can't log in with ssh, neither ftp or sftp. i think because of a firewall (norton) that i can't disable. my only way of accessing the space is through internet explorer ftp. i'm not sure whether it would/does show the .htaccess file. is there a way around this, or shall i just give up and spend more money on another server?

  4. skippy
    Member
    Posted 8 years ago #

    We're here to help. If you're willing to work with us, we're willing to work with you. It might take some time.

    It's entirely your choice whether to give up. If you're feeling frustrated, it might be worthwhile to cool off for a bit. I know it's maddening when things don't work as we want; but it's only a website. =)

    I don't know if Internet Explorer will show the .htaccess file, either; but you know it's there so you can manually try to access it. Though whether MSIE will let you delete it is another matter...

  5. jpettit
    Member
    Posted 8 years ago #

    i would doubt that moving to a new server would help you...you first need to figure out what is wrong. you should be able to FTP/SSH, etc from your computer. if not, i would work on getting that fixed (sorry i can't really help as i'm on a mac), but once you can FTP properly to your webserver, skippy is right...remove your .htaccess (it must be an ascii text file to begin with as well). if that fixes that problem, then you are a lot closer to fixing the issue.

  6. benwoodward
    Member
    Posted 8 years ago #

    unfortunately, i don't have my own computer right now, so i'm using the family pc that my father has completely locked down with every security measure possible and i can't change it.

    for the time being i am going to get the wireless network card working with the installation of linux i have created, and hopefully i can access my site that way.

    back later!

  7. skippy
    Member
    Posted 8 years ago #

    benwoodward: if you can login to your WordPress administration area, click on Options -> Permalinks. Define a permalink structure you want (one of the recommended suggestions should be fine for now), and click Update.

    If your .htaccess file is editable, the steps above should make the necessary changes.

    Let us know if that works.

  8. kickass
    Member
    Posted 8 years ago #

    Ben, most hosts these days have a cpanel or other type of domain admin access area. All of these (at least the ones I've used) have some sort of filemanager where ftp stuff can be done without an ftp program from within the browser. Also, you can edit files from there in your browser. Actually, with the .htaccess file, that's the only way I can access it. I use ftp but that file doesn't show on my ftp list. Anyway, if your webhost has cpanel or one of the other types of admin, maybe that's something that you could use since you can't reconfigure your dad's 'puter.

  9. benwoodward
    Member
    Posted 8 years ago #

    ok. i've got ssh access now, it doesn't show up any .htaccess file..

    i changed the permalink options like you said, and it's given mod_rewrite rules because apparently my .htaccess file isn't writable...

    hmm... any suggestions?

  10. skippy
    Member
    Posted 8 years ago #

    Because .htaccess is not writable, we can now rule that out as a cause of the problems you mentioned in your original post.

    But, if you like, ssh into your host and create a blank. htaccess file. Grant write permission to the file, then try Options -> Permalinks again.

    For completeness sake, try access your site's main page again, and see if things behave as you want them to.

  11. benwoodward
    Member
    Posted 8 years ago #

    ok.. does anyone know of a good page for beginners ssh? :)
    how do i make .htaccess writable with ssh? chmod?
    do i use touch .htaccess to create the file...

    i think part of the problem may be that i'm using a masked domain..
    if i goto the hostspace: - http://benwoodward.nfshost.com/ and hover over links the status bar links to http://www.benwoodward.net/2005/07/06/test2/ for example, but this domain is just a forwarder.. could this be the problem?

  12. benwoodward
    Member
    Posted 8 years ago #

    ok. i changed the uri for blog adress in the options and now the permalinks give 404's instead of going back to the homepage...

  13. skippy
    Member
    Posted 8 years ago #

    The domain may be an issue. What do you have set for the URI fields in Options->General?

    quickie ssh tutorial:
    ssh user@example.com
    $ cd public_html/blog/
    $ touch .htaccess
    $ chmod 777 .htaccess

    Go to Options -> Permalinks. Save your permalink settings, and let WordPress construct rewrite rules for you. Then go back to your terminal:

    chmod go-w .htaccess

    Done. For now, at least.

  14. benwoodward
    Member
    Posted 8 years ago #

    haha.. i took out the permalink structure and it now works!

    it was a uri problem

    but no!!! comments aren't working... could <i>this</i> be to do with .htaccess?

  15. benwoodward
    Member
    Posted 8 years ago #

    comments are going in but an error page always springs up after submitting them;

    Warning: gethostbyaddr(): Address is not a valid IPv4 or IPv6 address in /nfsn/content/benwoodward/htdocs/wp-includes/functions-post.php on line 472

  16. benwoodward
    Member
    Posted 8 years ago #

    i have found these two posts of revelance in my webhost forums, but i don't understand!

    https://www.nearlyfreespeech.net/members/forums/viewtopic.php?t=598&highlight=gethostbyaddr

    https://www.nearlyfreespeech.net/members/forums/viewtopic.php?t=513&highlight=gethostbyaddr

    can anybody make sense of what going on?

  17. skippy
    Member
    Posted 8 years ago #

    I'm presented with a member login.

  18. benwoodward
    Member
    Posted 8 years ago #

    ok. got it working thanks to what was said in this post - http://wordpress.org/support/topic/29694

  19. benwoodward
    Member
    Posted 8 years ago #

    p.s. thanks for all the help! very much appreciated, and encouraging. thankyou.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.