WordPress.org

Ready to get started?Download WordPress

Forums

Database ? phpmyadmin : sub sites with in network not working (9 posts)

  1. tmw27529
    Member
    Posted 2 years ago #

    When I enter a new site with in the Network Admin section it does create wp_2_option, however the new site url and url/wp-admin is not found on the server. The blogs.dir is in the wp-content folder with 755 permissions. The htaccess is

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    wp-config

    define('WP_DEBUG', false);
    
    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'waccamawtransport.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    /* That's all, stop editing! Happy blogging. */

    with in phpmyadmin > DB information_schema > schema_privileges the table_catalog is NULL but all privilege_types is_granted yes, also DB information_schema > user_privileges table_catalog NULL / privilege_type USAGE / is_granted NO. Does this mean anything?

    The site I am working on is http://waccamawtransport.com/wp-index.php
    The index.php file is not up b/c client does not want to switch yet. But I did make it live to test the sub site out and it still did not solve anything. here is link to the sub site http://waccamawtransport.com/employee

    I am new to this network stuff and thought I was dong rather well until this. UH! I really want to solve this issue before the server guy does. He is a pain in the butt and has given me hell every step of the way for even trying to use wordpress. Im sure the guy is testing out his own theories so please bare with me if the links arent as mentioned.

  2. tmw27529
    Member
    Posted 2 years ago #

    8 hours later I do not believe that table_catlog NUll is wrong. How ever I still think its something server/database that is going on.

    So I found this info which is useful (I think?). Should I ask the server guy about this?

    PhpMyAdmin is a web tool for administering (and browsing) mysql based databases. Its extremely useful, and we installed it when we put php on (if you didn’t then yum --enablerepo=remi install phpmyadmin will do it), but the default configuration is to only allow access from localhost – which is not so useful on a NAS. So lets open that up so that the local subnet can use it. First edit the file /etc/httpd/conf.d/phpMyAdmin.conf and add the additional line to the directory settings:

    <Directory /usr/share/phpMyAdmin/>
    order deny,allow
    deny from all
    allow from 127.0.0.1
    allow from 192.168.1.0/15
    </Directory>If you wanted to allow access to everybody then you could just change it to:

    <Directory /usr/share/phpMyAdmin/>
    order allow,deny
    allow from all
    </Directory>A restart (service httpd restart) is enough to pick this up. One other change that may be worth making is to add rewrite rules to force SSL on this connection. To do that we need to change the root virtual host config in /etc/httpd/conf/httpd.conf – adding in the two extra rules below:

    <VirtualHost *:80>
    DocumentRoot /home/apache
    ServerName yourhost.dyndns.org
    ErrorLog /var/log/httpd/error_log
    CustomLog /var/log/httpd/access_log combined
    RewriteEngine On
    RewriteRule ^/cube/(.*)$ https://mail.yourhost.dyndns.org/$1 [R=301,L]
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/phpmyadmin/(.*)$ https://%{HTTP_HOST}/phpmyadmin/$1 [R,L]
    RewriteRule ^/phpMyAdmin/(.*)$ https://%{HTTP_HOST}/phpmyadmin/$1 [R,L]
    </VirtualHost>After doing another restart (service httpd restart) you should be able to access http://ip address/phpmyadmin to access the database. The username and password you are prompted for it the database username and password.

  3. tmw27529
    Member
    Posted 2 years ago #

    If the database is creating the tables for the new network sites then httpd.conf file should already be ok?

    I so need a beer and its only 7:51am here :/ I fully expect to rip all my hair out today.

    Please help! Ill buy you a beer!

  4. CoderJosh
    Member
    Posted 2 years ago #

    phpMyAdmin would help you to debug database problems, but as I see it, that's rather a rewriting issue:

    Your rules in .htaccess rewrite certain URLs to index.php, but as you said, you don't have this file up yet. Instead you currently have wp-index.php, so your rewrites should go there for now.

    There might be other issues as well, but that's what I'd try first.

  5. tmw27529
    Member
    Posted 2 years ago #

    Thanks! I tried it out but still not working. Does it take some time for that file to kick in or anything? (sorry for my ignorance)
    Here is what I changed it to

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^wp-index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . wp-index.php [L]
    # END WordPress
  6. CoderJosh
    Member
    Posted 2 years ago #

    Changes made in .htaccess files are in effect instantly.

    As none of the rewrite rules seem to work, check your server configuration to see if rewrite rules are allowed in .htaccess files and double check the .htaccess file's file permissions to be sure that the web server can read it.

  7. tmw27529
    Member
    Posted 2 years ago #

    .htaccess is 755 how do I check the server configuration?

  8. tmw27529
    Member
    Posted 2 years ago #

    take that back .htaccess is 777

  9. You can fart around with haccess all day - if the server is not actually reading it (which is what is happening here) then you're just running around in circles.

    Go into httpd.conf via the command line. Change it to AllowOverride FileInfo Options for that vhost.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.