WordPress.org

Ready to get started?Download WordPress

Forums

Database not found - I read and tried several other solutions! (6 posts)

  1. breezotoo
    Member
    Posted 3 years ago #

    I am attempting to set up two wordpress sites on 1plus1 servers.
    Now I have one up and running, so I get the idea. Not that I really know what I am doing!
    By the way this one works in the root directory. Simple.

    The two new domains are on a single server, which means I had to

    point
    the destination directory
    so I have mysite.com/mysite/wordpress - for each
    I have set up the config files with the details, name host and password.
    I FTP'd everything in place.

    Everything I do - the result is no database can be found. Nada...

    What am I overlooking?
    How else can I check?

    Thanks

  2. freeandeasyblog
    Member
    Posted 3 years ago #

    You may want to double check and make sure that the config.php file has the correct information to connect to the database.

    // ** MySQL settings - You can get this info from your web host ** //
    define('WP_CACHE', true);
    define('DB_NAME', 'databasename');
    define('DB_USER', 'databaseuser
    define('DB_PASSWORD', 'thedatabasepassword');
    define('DB_HOST', 'localhost'); // if the database is hosted locally then "localhost" best. If the database is hosted remotely then the IP address or hostname goes here
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    Also make sure the database user has been granted the correct permissions to the database that it is a user for.

  3. freeandeasyblog
    Member
    Posted 3 years ago #

    Looks like my last post left out a parenthesis sorry about that:

    // ** MySQL settings - You can get this info from your web host ** //
    define('WP_CACHE', true);
    define('DB_NAME', 'databasename');
    define('DB_USER', 'databaseuser');
    define('DB_PASSWORD', 'thedatabasepassword');
    define('DB_HOST', 'localhost'); // if the database is hosted locally then "localhost" best. If the database is hosted remotely then the IP address or hostname goes here
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

  4. breezotoo
    Member
    Posted 3 years ago #

    Yes this piece is correct - I followed this to the letter based on all the previous posts on similar errors - this is obviously an area new folks, like myself start out in not knowing anything!

    OK, one of my sites is now working - the host made some changes, I cleared my cache etc and viola!

    This site I had running before the host installed another domain on it.
    So site number two is still work in progress.
    I'll re work the config file line by line and see how that goes!

    Much obliged

  5. breezotoo
    Member
    Posted 3 years ago #

    It seems as if there was a set up issue on the hosting side...

    Drove me nuts!

    Thanks for helping!

    Graeme

  6. techbrij
    Member
    Posted 2 years ago #

    See following step by step guide to fix this error:
    Error establishing a database connection – WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic