WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Database import impossible using phpmyadmin (5 posts)

  1. su1
    Member
    Posted 3 years ago #

    I am moving one of my wordpress blogs from a shared server to a dedicated server (both hosted at 1&1).

    I have a problem when trying to import my old database saved as a sql file in my new phpmyadmin. I get this error message:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?xml version="1.0" encoding="utf-8"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1' at line 1

    Both the shared server and the dedi run mysql 5.

    I precise that I use weird characters in my database (french accents, etc...) so maybe the error come from here?

    I don't know what to do, if you need more information about my settings please let me know.

    Thanks.

  2. fonglh
    Member
    Posted 3 years ago #

    that doesn't look like an sql file, how did you export your data?

  3. su1
    Member
    Posted 3 years ago #

    I used phpmyadmin on my old server, under the "export" tab.

    "SQL"-> for output format,
    Checked "Structure"
    Checked "Add AUTO_INCREMENT" value
    Checked "Enclose table and field name with backquotes".
    Checked "DATA"
    checked use "hexadecimal for binary field"
    Export type set to "INSERT".

  4. Michael Bishop

    Posted 3 years ago #

    I concur, make sure you are selecting the sql file, and not the export file from the WordPress Tools->Export which would be XML.

  5. su1
    Member
    Posted 3 years ago #

    Well somehow an html file was generated, I don't know why. I exported my database one more time and it works now. thanks

Topic Closed

This topic has been closed to new replies.

About this Topic