WordPress.org

Ready to get started?Download WordPress

Forums

Database errors when activating MailPress on WP 3.0 in MS mode (5 posts)

  1. RavanH
    Member
    Posted 4 years ago #

    Hi,

    I noticed some weird behaviour by MailPress 5.0 activated on a sub-site of a WP 3.0 installation in Multi-site mode. Somehow there seems to be some user data (like Newsletter category subscribtion and geotag info) missing. In the PHP error log I find:

    [19-Jun-2010 22:35:53] WordPress database error Multiple primary key defined for query ALTER TABLE 4V_6_mailpress_mailmeta ADD PRIMARY KEY (meta_id) made by activate_plugin, do_action, call_user_func_array, MailPress->install, include, dbDelta
    [19-Jun-2010 22:35:53] WordPress database error Multiple primary key defined for query ALTER TABLE 4V_6_mailpress_mails ADD PRIMARY KEY (id) made by activate_plugin, do_action, call_user_func_array, MailPress->install, include, dbDelta
    [19-Jun-2010 22:35:54] WordPress database error Multiple primary key defined for query ALTER TABLE 4V_6_mailpress_stats ADD PRIMARY KEY(stype, sdate, slib) made by activate_plugin, do_action, call_user_func_array, MailPress->install, include, dbDelta
    [19-Jun-2010 22:35:55] WordPress database error Multiple primary key defined for query ALTER TABLE 4V_6_mailpress_usermeta ADD PRIMARY KEY (meta_id) made by activate_plugin, do_action, call_user_func_array, MailPress->install, include, dbDelta
    [19-Jun-2010 22:35:56] WordPress database error Multiple primary key defined for query ALTER TABLE 4V_6_mailpress_users ADD PRIMARY KEY (id) made by activate_plugin, do_action, call_user_func_array, MailPress->install, include, dbDelta

    What's wrong?

    http://wordpress.org/extend/plugins/mailpress/

  2. robanna
    Member
    Posted 4 years ago #

    I got the same errors and my posts load REALLY slow.

    Ever find an answer?

  3. RavanH
    Member
    Posted 4 years ago #

    No, no answers... I'd post this on the MailPress Google Group on http://groups.google.com/group/mailpress but I cannot access those pages ( for some reason I seem to be banned ;( ) so maybe if you post this there you might get some response ?

  4. robanna
    Member
    Posted 4 years ago #

    I've been talking with the developers on the group. I'll let you know if I find anything out.

  5. Rhand
    Member
    Posted 4 years ago #

    Any news on this issue?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags