WordPress.org

Ready to get started?Download WordPress

Forums

Database errors on install with PHP 5, MySQL 5 and IIS (4 posts)

  1. packetrat
    Member
    Posted 8 years ago #

    I have a fresh server, configured with PHP 5 on Microsoft IIS, with MySQL 5 installed. I got the following errors in step 2 of install"

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://blog.carthik.net/index.php', 'Carthik', 1, 'http://blog.carthik.net/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://blogs.linux.ie/xeer/', 'Donncha', 1, 'http://blogs.linux.ie/xeer/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://zengun.org/weblog/', 'Michel', 1, 'http://zengun.org/weblog/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://boren.nu/', 'Ryan', 1, 'http://boren.nu/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://photomatt.net/', 'Matt', 1, 'http://xml.photomatt.net/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://zed1.com/journalized/', 'Mike', 1, 'http://zed1.com/journalized/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://www.alexking.org/', 'Alex', 1, 'http://www.alexking.org/blog/wp-rss2.php');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://dougal.gunters.org/', 'Dougal', 1, 'http://dougal.gunters.org/feed/');

    WordPress database error: [Field 'category_description' doesn't have a default value]
    INSERT INTO wp_categories (cat_ID, cat_name, category_nicename) VALUES ('0', 'Uncategorized', 'uncategorized')

    WordPress database error: [Field 'post_excerpt' doesn't have a default value]
    INSERT INTO wp_posts (post_author, post_date, post_date_gmt, post_content, post_title, post_category, post_name, post_modified, post_modified_gmt) VALUES ('1', '2005-12-08 17:30:13', '2005-12-08 22:30:13', 'Welcome to WordPress. This is your first post. Edit or delete it, then start blogging!', 'Hello world!', '0', 'hello-world', '2005-12-08 17:30:13', '2005-12-08 22:30:13')

    Warning: Invalid argument supplied for foreach() in c:\Inetpub\wwwroot\wordpress\wp-admin\upgrade-functions.php on line 30

    Help!

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Search is not the answer to everything - and especially when the link is broken.

    The problem you have is that mysql5.0 when run in strict mode does not like empty fields - that is why you are getting the error. Versions of mysql prior to 5 were more flexible in what was / was not permitted. Can you step down from Strict mode ?

    This issue has been discussed here before, and a search for mysql 5 and strict will show the discussions:
    http://wordpress.org/support/topic/50406
    http://wordpress.org/support/topic/48933
    are two such results.

  3. packetrat
    Member
    Posted 8 years ago #

    OK, I ditched strict. Actually had to flush the db and reinstall, because of some idiosyncracies of the MySQL instance. But it works now. Thanks....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.