WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Database Error message when creating a new page. (8 posts)

  1. NikolaAnne
    Member
    Posted 7 years ago #

    WordPress database error: [Unknown column 'none' in 'field list']
    INSERT INTO wp_post2cat (post_id, category_id) VALUES (15, none)

    Warning: Cannot modify header information - headers already sent by (output started at /home7/nikolaanne/webs/fluffenstuff/htdocs/wp-includes/wp-db.php:104) in /home7/nikolaanne/webs/fluffenstuff/htdocs/wp-includes/pluggable-functions.php on line 272

    This is a totally non messed with install, as I have no clue about pHp as yet...

    Ths posts are being saved and appearing though, which makes the error even more strange.

    Help!

  2. NikolaAnne
    Member
    Posted 7 years ago #

    Has no one any help for me?

    I found the Topic about this in the Codex, and tried to fix it myself.

    I copied the file that has theproblem from a fresh install of WordPress I have on another domain that works perfectly, and I'm still gettting the issue.

    I'm now wondering if the WP-Commerce lite Plugin I am using is giving me issues. It is the only different plug-in I have to my successfully working install. I will try to disable it, and see what happens...

    But hey, some other ideas are always welcome... Please?

  3. NikolaAnne
    Member
    Posted 7 years ago #

    OK, I've disabled all my plugins, and I'm still getting the error.

    I know someone else has a very similar thread to myself, the only commonality I can see is that she has v2.0.4 as well..

    Someone must have ideas...

  4. spencerp
    Member
    Posted 7 years ago #

    /Or, is that the same article you're talking about, already reading..? =P

    For the headers already sent error message, read this. For the Database errors there, I'm not a "pro" with that..but maybe someone else can help ya though. ;)

    spencerp

  5. NikolaAnne
    Member
    Posted 7 years ago #

    Yes Spencer, I found and read that, the same as jdlejeune did in their support thread, and checked the erroring files as specified for white space.

    Heck, I even replaced the files in question with copies from the "good" install I have working with no issue at all on another domain.

    I also note from jdlejeune's thread, that the install they have performed is also in a "root" dir, rather than in a wordpress directory... So, I'm wondering if that may be an issue...

  6. NikolaAnne
    Member
    Posted 7 years ago #

  7. NikolaAnne
    Member
    Posted 7 years ago #

    Also, this thread
    http://wordpress.org/support/topic/71174

    Although, my default catagory was already ticked.
    The commonatily here is the WP-Commerce Plugin.
    But also again, a "root" install.

  8. NikolaAnne
    Member
    Posted 7 years ago #

    Hmm, I went and follwed the catagory advice in thehttp://wordpress.org/support/topic/71174?replies=6

    and I now seem to be able to add and edit pages with no hassles...

    So, I would guess it is to do with the "default catagory" no actually registering with the system?

    Anyone else seen this, and maybe cured it this way?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags