WordPress.org

Ready to get started?Download WordPress

Forums

Database Connection Problem (password ?) (5 posts)

  1. thornomad
    Member
    Posted 8 years ago #

    Hi,

    I am relatively new and this (and even newer with my Mac X.4.3).

    I have followed http://maczealots.com/tutorials/wordpress/ guide for installing PHP/mySQL. I believe to have the foundation established correctly (if I run a test PHP page, I get the right output). I have a database created called 'wordpress'. I have changed my wp-config.php file to define the name, user (as root), and my password (which works in the shell command). the host is set to localhost.

    However, when I go to install.php, I get an "Error establishing a database connection".

    I am running mySQL 4.1.15 -- I have read of some people warning against using anything about 4.0, however, I could get any of the downloaded files from mySQL to install from 4.0 and went with 4.1. I also have read the Install_Guide on the codex and tried to use the suggestion for enabling correct permissions ... however, I can't get the code to run correctly: after the "GRANT ALL PRIVILEGES" and "IDENTIFIED BY" code, I don't get an OK -- I get another "->".

    So: I guess I am sort of lost as to what I should do.

    do you have any suggestions ?

    Thank you!

    Damon

    PS: I don't know if it was clear or not, but I am doing a local installation -- I want to test it out and get it running before I put it live. Thanks!

  2. emorgoch
    Member
    Posted 8 years ago #

    Firstly, I'd create a new user in your database just for wordpress to use, and grant them full permissions on the wordpress database. Secondly, MySQL 4.1 uses a different password 'format' compared to 4.0 by default, so what you need to do is specify that you want to use the old pass word. Do this by gettng into the MySQL console, and then set the password to the old format by using:
    mysql> SET PASSWORD FOR
    -> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');

    That should take care of it.

  3. thornomad
    Member
    Posted 8 years ago #

    Thank you thank you!

    I didn't create new user -- I used "root" -- because I don't know how to do that. *smiles sheepishly* However, I typed in the bit of code you suggested and wa la! It works.

    thank you!

    I feel really inadequate at this SQL server side stuff and unix commands ... is there a good book (or is it really even necessary) that would help me use WordPress better ?

    Damon

  4. moshu
    Member
    Posted 8 years ago #

    If it's up and running - all you need is the Codex

  5. emorgoch
    Member
    Posted 8 years ago #

    Second option: Go here and put PHPMyAdmin on your webserver. It'll give you a reasonable GUI interface to perform tasks with, such as creating new databases, making new users, etc.

Topic Closed

This topic has been closed to new replies.

About this Topic