WordPress.org

Ready to get started?Download WordPress

Forums

Database connection problem (11 posts)

  1. TheOneAndOnly
    Member
    Posted 9 years ago #

    Greetings All,

    MajorLeagueNewbie. Struggling with install. Don't know what went wrong. When I direct browser to install.php, it gives me this message:

    [i]We're having a little trouble selecting the proper database for WordPress.

    * Are you sure it exists? ((Yes it does))
    * Your database name is currently specified as username_homepage-wp. Is this correct? ((Yes it is))
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem? ((I don't think so, since I'm aware of this.))[/i]

    Sorry, getting stuck there doesn't give you much info. Problem is, it doesn't give me much either.

    Any and all help would be greatly appreciated,

    TOAO

  2. BuffyVS
    Member
    Posted 9 years ago #

    I would triple check the database name, username and password you put into the wp-config.php. Same thing happened to me before with a different blog system a few months back.. Here the problem was that I mistyped one wrong letter as the database name

  3. TheOneAndOnly
    Member
    Posted 9 years ago #

    The one thing the directions didn't say at Wiki was WHAT to upload. Yes, it said the entire contents of the decompressed folder with the aforementioned adjusted files. Still, that folder was called WORDPRESS and I wasn't sure if I could just drag said folder into my public folder onto my server.

    I did. Left it as /wordpress/ and placed it here:

    http://www.mydomainname.com/wordpress/wp-admin/install.php

    I don't need to put 'public_folder' into that line, do I?

    (Thanks for trying...)

  4. DianeV
    Member
    Posted 9 years ago #

    > I don't need to put 'public_folder' into that line, do I?

    No, because "public_folder" is part of the internal file structure path on the server, whereas http://domainname.com/etc. is the http address.

    If you are getting that error message after accessing install.php, it means that you've got the correct path to WordPress at your website, and that it's trying to set up the blog.

    Where you get the error is where the problem is. I'd recheck the info you put into the wp-config.php, as that is most likely to be the problem -- and often the easiest thing to get wrong. For instance, it sounds like you're using a commercial web host; these often want you to use your domain name instead of "localhost". Little things like that can cause a problem.

  5. TheOneAndOnly
    Member
    Posted 9 years ago #

    Going in circles folks. I swear I'm doing everything right and still NOTHING. So I'm going to walk you through exactly what I'm doing, hoping this reveals something.

    Firstly, I'm a Mac OS 10.3 user with iPowerWeb as host, if that sets off any issues with other users off the bat.

    1. I've successfully created a database and username.

    2. Now I download the latest WP (1.2.2 Mingus) from this page: http://wordpress.org/download/

    3. I carefully follow the instructions on wiki 5 minute install page:

    http://wiki.wordpress.org/?pagename=5MinuteInstallation%2Fwp-config.php

    4. One thing I couldn't quite do in these instructions lives is: "# On Mac OS X TextEdit is ideal for editing simple files like this (remember to choose Plain Text from the Format Menu)." The truth is no such option exists in the format menu of TextEdit.

    HMMM: However it DOES exist in preferences, and it was defaulted to RICH TEXT instead of plain text.

    5. Here's what I changed:

    // ** MySQL settings ** //
    define('DB_NAME', 'account_homepagewp'); // The name of the database
    define('DB_USER', 'account_username'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    6. Saved changed file to name: wp-config.php

    (Because of discovery in #4, I changed said file AGAIN and reuploaded it seperately. That's cool, right? It doesn't need to be uploaded with the folder to work?)

    6. I aimed the file at:

    http://www.mydomain.com/wordpress/wp-admin/install.php

    RESULT: same messages!

    ARRRGGGGHHHHH!

  6. TheOneAndOnly
    Member
    Posted 9 years ago #

    A TANGENT: I was told I could publish my BLOG in my public folder. It now occurs to me that this may make my username and password rather easy to see. Is that true?

    If I put the blog in a more discreet location on the server (where iPW seemed to install it's own b2 blog software), would that keep my info more private?

    Thanks for all help guys and gals!

  7. TheOneAndOnly
    Member
    Posted 9 years ago #

    By the way, what does "Remove all leading spaces before any of the above details" mean? Are there any?

  8. TheOneAndOnly
    Member
    Posted 9 years ago #

    WELL, iPowerWeb instructed that I throw out EVERYTHING and start again from scratch. I did and graduated up to a new user error instead, which at least, in some way, is progress I guess:

    "Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.

    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?"

  9. mycw
    Member
    Posted 9 years ago #

    If you're using PHP 4.3.9 and MySQL client/server 4.1 you may actually get the following error while connecting during installation.

    Error w/ php: mysql_connect(): Client does not support authentication protocol

    You can verify this problem by editing wp-includes/wp-db.php. Look under function wpdb. Change the last line in the 'die' statement to
    </div>" . mysql_error());
    i.e adding mysql_error() so you actually see the MYSQL error.

    If you get the above MYSQL error then you can fix this by doing logging into mysql and do the following:

    SET PASSWORD FOR 'user'@'localhost' = OLD_PASSWORD('password');

    Also checkout: http://forums.mysql.com/read.php?11,6400,6701#msg-6701

    This fixes the "Error establishing a database connection" problem for me.

  10. TheOneAndOnly
    Member
    Posted 9 years ago #

    THANKS ALL. Problem resolved, but kinda sorta in a weird way. Again, I'm using iPowerWeb, and so I went to their online help for some help. It's like AIMing your host. Anyway, they said I had the password wrong. IMPOSSIBLE I said, since between two install attempts the password was the only constant. Still, she insisted it was wrong. She said my password wasn't 'associated' with my username. This tells me I misunderstood their software they call v-deck. So although everything looked okay from our point of view, she had an insider point of view which indicated things were not as they appeared. I'm too wiped to get the full explanation, but next time I set up a username/password, I'll pay closer attention.

    Sorry to drive any of you half as crazy as I've been!

    LOL

  11. NuclearMoose
    Member
    Posted 9 years ago #

    Glad you got it working!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.