WordPress.org

Ready to get started?Download WordPress

Forums

Database Collation / encoding issues..posts are showing wierd characters (2 posts)

  1. mikecicc
    Member
    Posted 5 years ago #

    So I am working on a WP site, some customizations were needed and I wanted to make these changes locally using MAMP then upload the new files to the remote site when I'm finished.

    I exported the current live database which is in latin1_swedish_ci Collation and imported the tables to my local host (phpmyadmin). My first try I used UTF8 for the collation on my DB which is default and I've never had a problem in the past using this Collation, but when I got the site running all the posts have this strange à (an A with a symbol above it) symbol at the end of almost everything sentence.

    So I started over again, this time assigning my local database the same Collation, latin1 (the closest available option to latin1_swedish_ci) and Now I have two à (an A with a symbol above it) symbols at the end of almost every sentence inside the posts.

    I have no idea about this whole character encoding jazz, and it's pretty unforninuate for me.

    Any help, at all would be greatly appreciated!

  2. mikecicc
    Member
    Posted 5 years ago #

    NEVERMIND! FOR ANYONE HAVING SIMILAR PROBLEMS ALL I HAD TO DO WAS REMOVE utf8 from the following line: define('DB_CHARSET', 'utf8'); WHICH APPEARS TO BE A NEW ADDITION TO WP-CONFIG.PHP WITH LATER VERSIONS OF WORDPRESS

Topic Closed

This topic has been closed to new replies.

About this Topic