WordPress.org

Ready to get started?Download WordPress

Forums

Network Plugin Auditor
[resolved] Data too long for column 'option_name' (6 posts)

  1. Marc
    Member
    Posted 1 year ago #

    We keep getting a bunch of these in our error log every time I load the network plugins page, network themes page, but NOT for the sites page. Which, I assume, is because caching wasn't implemented for that page.
    The plugin appears to be working just fine, it's just cluttering our error logs.
    I googled the general error and it was suggested to check the table collation type, but it was already utf8_general_ci like it should be.
    I also found that the option_name field is varchar(64) and all of the values being inserted are longer than that. So that seems the be the problem, but I'm not sure how you'd want to handle that. Hope this is helpful.
    Is anyone else seeing this in their logs?

    [04-Jan-2013 21:08:49] WordPress database error Data too long for column 'option_name' at row 1 for query INSERT INTO 'wp_options' ('option_name', 'option_value', 'autoload') VALUES ('_transient_timeout_networkauditor_plugin_email-alerts/email-alerts.php', '1357337329', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value' = VALUES('option_value'), 'autoload' = VALUES('autoload') made by require('C:\htdocs\webminis.tyndale.com\wp-admin\plugins.php'), WP_List_Table->display, WP_List_Table->display_rows_or_placeholder, WP_Plugins_List_Table->display_rows, WP_Plugins_List_Table->single_row, do_action('manage_plugins_custom_column'), call_user_func_array, NetworkPluginAuditor->manage_plugins_custom_column, NetworkPluginAuditor->is_plugin_active_on_blogs, set_transient, add_option</p>

    There is NOT an error for every plugin on our network, but I'd say most of them seem to be generating values that are too big.
    Another thing to note is that we only get one error logged for the themes page. If it's helpful, the value being inserted is:
    '_transient_timeout_networkauditor_theme_love-isnt-supposed-to-hurt'

    http://wordpress.org/extend/plugins/network-plugin-auditor/

  2. Katherine Semel-Munson
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the bug report! The newest version of the plugin (1.3.1) should fix this issue. Let me know if you're still seeing errors in your logs after updating.

    - Kathy

  3. Marc
    Member
    Posted 1 year ago #

    thanks so much. it seems to have helped a bit.
    but we are still getting errors, but now for only 4 of our plugins on the plugins page and still the one theme.

    the values:

    _transient_timeout_networkauditor_plugin_/enable-media-replace.php
    _transient_timeout_networkauditor_plugin_jet4_simple_mobile_page.php
    _transient_timeout_networkauditor_plugin_/really-simple-captcha.php
    _transient_timeout_networkauditor_plugin_/sticky-custom-post-types.php

    _transient_timeout_networkauditor_theme_love-isnt-supposed-to-hurt

    let me know if any other information would be helpful.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    As is noted in the set_transient article, transient names must be under 45 characters long. You need to add some sanity checking to the plugin to account for this.

  5. Katherine Semel-Munson
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the set_transient info!

    I've fixed up the code to trim down the names further to fit that 45 character limit, version 1.3.2 should fix the remaining errors.

    - Kathy

  6. Marc
    Member
    Posted 1 year ago #

    looks like that did it. thanks for the quick fix, as well as the ridiculously useful plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.