WordPress.org

Ready to get started?Download WordPress

Forums

Top 10 - Popular posts plugin for WordPress
[resolved] Data saving to wp_top_ten instead of wp_#_top_ten (6 posts)

  1. daneharnett
    Member
    Posted 1 year ago #

    Hi,

    I am having an issue with a network setup. It seems that it was previously working correctly however all of a sudden the data is now saving into wp_top_ten and wp_top_ten_daily instead of wp_#_top_ten and wp_#_top_ten_daily.

    The curious thing is, the display is looking at the correct table, so when viewing via a page widget or via the admin area I am not seeing any new data (only the old data from when it was working).

    We were running v1.7 but I upgraded on my local dev environment to v1.9.1 and am still experiencing the issue.

    Any ideas?

    http://wordpress.org/extend/plugins/top-10/

  2. Ajay
    Member
    Plugin Author

    Posted 1 year ago #

    Are you running the WordPress Multisite?

    I haven't tested Top 10 on a multisite installation yet, so am not sure what the behaviour of the plugin under this environment is.

    If you're not running multisite, can you please explain what you mean by wp_#_top_ten

  3. daneharnett
    Member
    Posted 1 year ago #

    Yes multi site.

    there is a table wp_9_top_ten which contains the data from when the plugin was working correctly. The "9" is the blog id

    It seems for some reason suddenly it is adding the data into wp_top_ten which i assume is the single site table.

    Its curious because the plugin looks into wp_9_top_ten when displaying the data.

    Dane

  4. Ajay
    Member
    Plugin Author

    Posted 1 year ago #

    I've taken a look at the code.

    addcount.js.php is the file that triggers the database update
    counter.js.php is the file that fetches the count and both use the same style of lookup

    I'll see to check the "right" way to look up tables in multi-site.

    Is the only change that you did was upgrade the plugin from 1.7 to 1.9.1 ?

  5. daneharnett
    Member
    Posted 1 year ago #

    Hi Ajay,

    I have found the issue in our code and rectified it. Nothing to do with the plugin.

    Thank you for taking the time with this issue.

    Cheers,

    Dane

  6. Ajay
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to know that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.