WordPress.org

Ready to get started?Download WordPress

Forums

Database name in multisite path (4 posts)

  1. lambyte0
    Member
    Posted 3 years ago #

    Hi.

    There were no errors during installation, and the Superadmin and main blog work. However, if I create a site, it won't work. If the site's admin logs in, wordpress will redirect them to some site which doesn't exist. I can manually change properties of the site as Superadmin to make it work, but I'm guessing I shouldn't have to.

    What's happening:
    1. Install WP
    2. Install subdomain multisite
    3. Create a site ("bob" in this case, user is "alice") in the Superadmin's site panel
    4. Log in as alice. I am then redirected to http://www.lambyte.comlambyte_com_2bob, (which is my domain + wordpress's database + site name) which does my browser tells me does not exist.
    5. Clear my cookies and whatnot so that I can login as Superadmin
    6. In the sites panel, edit the bob site's path to /bob/. Now everything works!

    Evidence:
    I am using Dreamhost.
    Subdomain install of Multisite.
    My database name is lambyte_com_2

    Possibly relevant info from Superadmin Sites panel:

    Editing Site - http://www.lambyte.comlambyte_com_2bob
    
    Site info (wp_blogs)
    ---
    Domain: http://
    [lambyte.com]
    
    Path: [lambyte_com_2bob]
    
    ...
    
    Site options (wp_y2fek1_3_options)
    ---
    
    Siteurl: [http://www.lambyte.comlambyte_com_2bob/]
    ...
    Home: [http://www.lambyte.comlambyte_com_2bob/]
  2. Oh dream host... Check your WP-config file for something like a base define for that eXtra domain name.

  3. lambyte0
    Member
    Posted 3 years ago #

    I appreciate your trying to help, but I don't understand. There are a couple lines which kind of fit that description:

    wp-config.php

    //Multisites install
    ...
    $base = '/';
    ...
    /* Stop editing */
    ...
    $base = DB_NAME;

    I'm guessing you mean by "extra" that the second $base = should be removed. Is that it?

  4. Yeah, comment out that extra Base.

    Change it to // $base = DB_NAME;

    Sorry, I couldn't find my notes on that last night!

Topic Closed

This topic has been closed to new replies.

About this Topic