WordPress.org

Ready to get started?Download WordPress

Forums

124

Godaddy free hosting - Dashboard / Admin broken (102 posts)

  1. shaner2000
    Member
    Posted 5 years ago #

    Fresh install of WordPress 2.8.
    Using Godaddy.com free economy hosting.
    Website looks fine: http://www.21105oakdale.com.
    I can login in to dashboard admin fine.

    However, it appears the dashboard has no formatting - ie, it appears it is not calling the css correctly.

    (I'm a novice but have somewhat of an understanding of this stuff).

    I've tried reinstalling the wp-admin and wp-includes folders.
    I've tried resetting the cache and cookies.
    I've tried refreshing the permalinks.

    All of the above were tips I found on the WP forums.

    Unfortunately, none has worked thus far.

    Any tips?

  2. shaner2000
    Member
    Posted 5 years ago #

    Just figured out it works fine with IE 7.0 but not firefox 3.0.11.

    Wonder if a firefox plugin is the problem?

    Either way, I guess I'm stuck with IE for now.

  3. shotime1
    Member
    Posted 5 years ago #

    I'm having the same problem. Using IE8 fixed it, but using latest versions of Firefox and Chrome won't work.

  4. shotime1
    Member
    Posted 5 years ago #

    Ok, I take that back. Now the dashboard looks fine, but it still doesn't have functionality. For example, on the widgets page I can actually move the elements around. Here's the error IE gets:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
    Timestamp: Mon, 15 Jun 2009 17:03:09 UTC

    Message: Syntax error
    Line: 24
    Char: 1
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=d24248fe4b0cd62086633fd42ef1019b

    Message: Object expected
    Line: 802
    Char: 11
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/widgets.php

    Message: Syntax error
    Line: 56
    Char: 1
    Code: 0
    URI: http://stanfordlawyers.com.previewdns.com/blog/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,jquery-ui-core,jquery-ui-sortable,jquery-ui-draggable,jquery-ui-droppable,admin-widgets&ver=2203e0189e7d540d81024839750b0838

  5. moebis
    Member
    Posted 5 years ago #

    I'm having the exact same issue with GoDaddy.com free hosting. Tried everything. I've found 2 or 3 threads on the net regarding this exact issue, and they all just end after 3 or 4 posts.... with no solution. This is a real issue. You can only use the 2.8 wp-admin on IE8 (Yuck!) otherwise, Safari, Chrome, Firefox it looks like it's missing the CSS.

    One blog mentioned changing all the permissions to the uploaded wordpress install to 755, which I did, but it didn't change a thing. He had 3 comments on his blog, the user said he still couldn't get it to work, and the only suggestion given was to flush the browser cache (duh!).

    Any help? BTW, I've also tried 2.8.1 beta 1 - 2.8.1 beta 2 - 2.8.1 nightly ......none work, so I doubt the WP devs are aware of this.

  6. itsfashionbaby
    Member
    Posted 5 years ago #

    Did you try to switch of your gear plugin?

    That did the trick for me - and btw I had the exact same problem and I'm not using Godaddy.

  7. moebis
    Member
    Posted 5 years ago #

    This is a fresh install. Are you talking about Google Gears, to speed up the backend? Don't you need to enable it first to use it? What do you do to "switch the gear plugin?"

    Thanks.

  8. itsfashionbaby
    Member
    Posted 5 years ago #

    Yes it's google gears, I'm referring to.

    And yes, if you haven't enabled it, that can't be causing your problems.

  9. silverhack
    Member
    Posted 5 years ago #

    Has there been any progress on this problem? I'm still having the problem, even after the 2.8.4 update. I don't have Google Gears installed. The website does not work correctly in Firefox or Chrome. IE seems to display the pages correctly, but still has a few problems (can't move widgets around).

  10. standards
    Member
    Posted 5 years ago #

    I solved the problem for dashboard not using/finding CSS setting permissions for load-styles.php (in wp-admin directory) to 0755.

    I solved the problem for managing/moving widgets setting permissions for widgets.dev.js (in wp-admin/js directory) to 0755.

  11. eljlstudio
    Member
    Posted 4 years ago #

    Has anyone found a solution to this problem? My admin screens are borked up since I upgraded to 2.8.4, and I cannot seem to find a solution.

  12. iridiax
    Member
    Posted 4 years ago #

    Free web hosting just does not work well with WordPress because the web host inserted ads, tracking code, and/or frames mess things up.

  13. Carolina Vigna-Maru
    Member
    Posted 4 years ago #

    Has anyone found a solution to this problem? My admin screens are borked up since I upgraded to 2.8.4, and I cannot seem to find a solution. [2!]

    Not using free hosting.

  14. thorsso
    Member
    Posted 4 years ago #

    Hello, excuse for my english. The problem on admin interface is in the free hosting solution of godaddy, infact godaddy web server append this code at end of the page:
    <<
    </iframe></noscript></object></layer></span></div></table></body></html><!-- adsok -->
    <script language='javascript' src='https://a12.alphagodaddy.com/hosting_ads/gd01.js'></script>
    >>

    The procedure of dynamic include, in the admin interface, of CSS and JS produce a file with the code added from godaddy webserver, the browser interpreter fails to recognize the mime type.
    The solution is to modify the script that load dynamically JS and CSS, in the file: wp-includes/script-loader.php.
    The admin interface is more slowly but work fine ...

    That's all!

  15. llizard
    Member
    Posted 4 years ago #

    How exactly are you modifying the script, Stefano?

  16. thorsso
    Member
    Posted 4 years ago #

    Hello,
    the script was modified in 2 points.

    First point the script load JS:

    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $src );
    $st_data = substr( $st_data, 0, strrpos( $st_data, '</iframe>' ) );
    echo "<script type='text/javascript'>\n";
    echo $st_data;
    echo "</script>\n";
    // **********************************************
    // echo "<script type='text/javascript' src='" . esc_attr($src) . "'></script>\n";

    Second point the script load stylesheet:

    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $href );
    $st_data = substr( $st_data, 0, strrpos( $st_data, '</iframe>' ) );
    echo "<style type='text/css' media='all'>\n";
    echo $st_data;
    echo "</style>\n";
    // **********************************************
    //echo "<link rel='stylesheet' href='" . esc_attr($href) . "' type='text/css' media='all' />\n";

    In all 2 points, the line commented was originally in the source of wordpress 2.8.4.
    I had commented that and i had added the code over that.

    The JS or stylesheet was loaded into $st_data var ($st_data = file_get_contents( $href );), then cleaned for the tag added by godaddy ($st_data = substr( $st_data, 0, strrpos( $st_data, '</iframe>' ) );) and finally included in the output page (echo $st_data;) with the apposite start and end section tag.

    This code work fine for me.
    I hope that work fine for all.

  17. ckliffames1
    Member
    Posted 4 years ago #

    Stefano-

    Looks like you found a fix an no worries on the English mate.

    However, could you be more specific as to where you placed those 2 points in the wp-includes/script-loader.php? I've tried placing it in several spots but I keep breaking it more than it already was.

  18. thorsso
    Member
    Posted 4 years ago #

    Hello ckliffames1,
    i work with wordpress 2.8.4, italian version.
    Replace line 619 in function _print_scripts():
    echo "<script type='text/javascript' src='" . esc_attr($src) . "'></script>\n";
    with:
    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $src );
    $st_data = substr( $st_data, 0, strrpos( $st_data, '</iframe>' ) );
    echo "<script type='text/javascript'>\n";
    echo $st_data;
    echo "</script>\n";
    // **********************************************

    and replace line 686 in function print_admin_styles():
    echo "<link rel='stylesheet' href='" . esc_attr($href) . "' type='text/css' media='all' />\n";
    with:
    // **********************************************
    // Clean for godaddy free hosting
    $st_data = file_get_contents( $href );
    $st_data = substr( $st_data, 0, strrpos( $st_data, '</iframe>' ) );
    echo "<style type='text/css' media='all'>\n";
    echo $st_data;
    echo "</style>\n";
    // **********************************************

    My dashbord work fine, with this changes and godaddy free hosting.

  19. ekoloa
    Member
    Posted 4 years ago #

    Wow, that's fantastic, thank you 'stefano.torricelli'. Your solution worked great, except the godaddy ads at the top of my dashboard multiply by five when I'm on my main page. I'm not complaining, just letting you know, in case you happen to know why it's doing that.

  20. ekoloa
    Member
    Posted 4 years ago #

    Every action in the admin panel produces more ads. I have like 20 at the top of my page now.

  21. thorsso
    Member
    Posted 4 years ago #

    Ads godaddy is very very very ...

    Godaddy add ads as an iframe at end of the page this is the very problem.
    I add this script at end every page where i want to hide ads ...

    I use in my wordpress site the theme pyrmont-v2 this is located in:
    /wp-content/themes/pyrmont-v2, change the pyrmont-v2 with your theme, then open the script footer.php, this ends with </body></html>.
    Replace </body></html> with:

    </body>
    
    <script type="text/javascript">
            function hideGoDaddy(){
              if( ! ( null === document.getElementById( "conash3D0" ) ) ) {
                gDaddy = document.getElementById( "conash3D0" );
                if( 'none' === gDaddy.style.display ) {}
                else { gDaddy.style.display = 'none'; }
              }
            }
            setInterval("hideGoDaddy()", 1500);
    </script>
    </html>

    Now when you access to your wordpress home page the godaddy banner show for little time then this hide.
    The script is very sample if you apply this to:
    /wp-admin/admin-footer.php (limit the number of banner from dashboard).
    /wp-login.php (hide the banner from login page)

    Try this and give me a feedback.
    Thanks.

  22. thorsso
    Member
    Posted 4 years ago #

    Finally i found where is the problem.
    The dashboard load every plugin with the jquery function load (ajax load) that produce a GET function, for every GET godaddy server add an ads.
    Then i modified my function with that:

    <script type="text/javascript">
      // ADS godaddy son's 1 per plugin in dashboard
      function hideGoDaddy(){
        var bd = document.body;
        if( bd.childNodes.length > 0 ) {
          for( j = 0; j < bd.childNodes.length; j++ ) {
            if( 'IFRAME' === bd.childNodes[j].nodeName ) {
    			 gDaddy = bd.childNodes[j];
              if( 'conash3D0' === gDaddy.id ) {
                if( 'none' === gDaddy.style.display ) {}
                else { gDaddy.style.display = 'none'; }
              }
            }
          }
        }
      }
      setInterval("hideGoDaddy()", 2000);
    </script>

    Put this code at the end of wp-admin/admin-footer.php before of:

    </body>
    </html>

    This work fine for me, ad appear and then hide.
    A productive day of study...

  23. mwmalta
    Member
    Posted 4 years ago #

    I have this problem and it is not based off of free godaddy hosting... The load-script has an error and the css doesn't work. What do I do?

  24. velese
    Member
    Posted 4 years ago #

    Hello

    First of all, thank you Stefano for your help.
    I have modified the wp-includes/script-loader.php file with those 2 code fragments and the wp-admin/admin-footer.php for the ads.

    Unfortunately, I still have a problem.
    My dashboard does load better than before, it is organized, but it doesn't have any background color and I cannot move the modules; I click on the Screen Options but it doesn't show anything.
    This is a screenshot of my dashboard:
    http://velese.com/wrong_dashboard.JPG

    Can you please help? I don't know any code language, just tell me where to modify and what exactly, at what line, if you find the solution.

  25. thorsso
    Member
    Posted 4 years ago #

    Hello velese,
    the source of header for your login page is:

    <head>
    <title>Velese's Blog › Log In</title>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type"/>
    <link id="login-css" media="all" type="text/css" href="../wordpress/wp-includes/http://velese.com/wp-admin/css/login.css?ver=20090514" rel="stylesheet">
    </link>
    <link id="colors-fresh-css" media="all" type="text/css" href="../wordpress/wp-includes/http://velese.com/wp-admin/css/colors-fresh.css?ver=20090625" rel="stylesheet">
    </link>
    <meta content="noindex,nofollow" name="robots"/>
    </head>

    but the source of my login page is:

    <head>
    	<title>Stefano Torricelli &rsaquo; Collegati</title>
    	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    	<link rel='stylesheet' id='login-css'  href='http://www.stefano.torricelli.name/wp-admin/css/login.css?ver=20090514' type='text/css' media='all' />
            <link rel='stylesheet' id='colors-fresh-css'  href='http://www.stefano.torricelli.name/wp-admin/css/colors-fresh.css?ver=20090625' type='text/css' media='all' />
    <meta name='robots' content='noindex,nofollow' />
    </head>

    the values of href in my installation was correctly and my login page appear good, but in your not, your login page appear without stylesheet css loaded.

    Check your installation.

  26. velese
    Member
    Posted 4 years ago #

    Thank you very much, I will look into it.
    I think I know already what the problem is, just from analysing the differences in the code above.

    Could you please specify which file exactly needs to be modified? I'm just getting started with wordpress... is it wp-login.php from the main folder?

  27. thorsso
    Member
    Posted 4 years ago #

    Hello velese,
    you don't need to modify any script, after the installation the login page must load every css correctly, if that is not the problem is in the installation process.
    The first href in your login page is "../wordpress/wp-includes/http://velese.com/wp-admin/css/login.css?ver=20090514" rel="stylesheet"> but about me that must be href="http://velese.com/wp-admin/css/login.css?ver=20090514" rel="stylesheet">, i don't know why your href is not correct, and in your home page every href are correct.

    Compare your login page with my: http://www.stefano.torricelli.name/wp-login, look the source code, i only added the script to hide godaddy ads at end of the page, no other modify was maded.

    I suppose that your href was bad in your administration page too, but i don't see your source code...
    Excuse me if can't you a definitive solution.

  28. velese
    Member
    Posted 4 years ago #

    I first installed my wordpress blog in the folder velese.com/wordpress and I don't know why, but maybe when I installed it the second time in the velese.com folder, it may have kept the link with the wordpress folder...

  29. moebis
    Member
    Posted 4 years ago #

    stefano your modification works, but it breaks the WYSIWYG editor. Is there any fix for that?

    Also, an easier way to get rid of the GoDaddy ads is to use this in your CSS:

    #conash3D0
    {
    display:none;
    }

    I put it in the theme and admin css.

  30. thorsso
    Member
    Posted 4 years ago #

    Thanks moebis,
    your solution for hide ads godaddy is more better than mine.

124

Topic Closed

This topic has been closed to new replies.

About this Topic