WordPress.org

Ready to get started?Download WordPress

Forums

Live Dashboard
[resolved] dashboard turned white page (10 posts)

  1. ron.du
    Member
    Posted 1 year ago #

    just after installation dashboard got white and cant be access to dashboard at all

    http://wordpress.org/extend/plugins/live-dashboard/

  2. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Ron.du, can you tell me a bit more about what's happening? What version of WP are you using and are you using any other plugins that affect the dashboard?

    Mike

  3. CouponCodePlugin
    Member
    Posted 1 year ago #

    Hello, I got a white screen when I activated this on our test blog. Sorry for hijacking this thread, but I think it is very likely the same issue and I hope I can help to resolve it for other users.

    I am using the latest version of wordpress with no other plugins activated and the default theme is active.
    I have a dedicated 16 processor server with more than enough resources and more than enough ram assigned per account.

    Server Errors
    Checked the server error logs and could not see any recent issues, only old issues that I have previously addressed.

    Debug
    Flipped on wordpress debug mode in wp-config.php by adding:
    define('WP_DEBUG', true);

    Two errors were found which relate to the plugin:

    Notice: Only variable references should be returned by reference in /wp-content/plugins/live-dashboard/live-dashboard.php on line 64

    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters(). in /wp-content/plugins/live-dashboard/lib/live-admin/functions.php on line 27

    I suspect these two errors to be the culprit for the white screen.

    Looking forward to being able to test this plugin and see what it can do.

    Thanks

  4. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for that reply! Going by the Fatal Error causing the white screen, I take it that you're on PHP5.4. I can't test it on PHP5.4 myself right now, but I went through to make sure it's compatible. I'm updating to version 0.3.1 now, can you give it a go?

  5. CouponCodePlugin
    Member
    Posted 1 year ago #

    Hello, You are most welcome.
    we use the latest stable releases for everything on our server, but I see we are one minor update behind as we are using PHP version is 5.4.10.

    Updated plugin to latest version and activated. The following error now displays:
    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters(). in /wp-content/plugins/live-dashboard/lib/live-admin/lib/class.settings.php on line 109

    If you like, you can contact me via http://couponcodeplugin.com/contact-us/ so that I can give you login details for our test site. I will have the php updated to 5.4.11. If it works with 5.4.11, it will be backwards compatible, so you can be sure it will work with all previous php versions.

    Thanks

  6. CouponCodePlugin
    Member
    Posted 1 year ago #

    Any news Mike? I would love to trial your plugin but as of now, it will not activate, so I am stuck.

  7. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I haven't been on it as much as I usually try to be - have been very busy, but expect a fix in the next 2-3 days!

  8. CouponCodePlugin
    Member
    Posted 1 year ago #

    No problem, I just wanted to check in.
    As mentioned, I can provide you with access to our server so that you can test it with the latest php version.

    Thank you
    Dave

  9. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Dave, thanks for the offer, but I had some more testing to do in PHP5.4, so went ahead and set up a better dev environment ;) Anyway, made the tweaks and updated the live admin plugins. They should be working with PHP5.4 now!

    Mike

  10. CouponCodePlugin
    Member
    Posted 1 year ago #

    Hello and thank you for your continued support.
    I activated the plugin and it did so without any errors.

    It seems to be working now, so I will jump in and test it.

    Thanks again
    Dave

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic