WordPress.org

Ready to get started?Download WordPress

Forums

Dashboard issues: RSS Error: WP HTTP Error: name lookup timed out (18 posts)

  1. AC
    Member
    Posted 5 years ago #

    Hello!
    I believe I've had this issue ever since I upgraded to 2.8.1. The dashboard is running super slow and I see this following error in several of the content areas:

    RSS Error: WP HTTP Error: name lookup timed out

    Any ideas?

  2. James Ronaldo
    Member
    Posted 4 years ago #

    have u solved this issue or still facing it?

  3. acell
    Member
    Posted 4 years ago #

    Hi pixelmommy. I've got the same issue. 8.0 is fine, but 8.1, 8.2 & 8.3 cause the same issue.

    My backups no longer send, i get not notification of comments, no notification of plugin updates.. and no idea how to fix it :S

    If you have a solution please please reply :)

    thanks

  4. ashiado
    Member
    Posted 4 years ago #

    Exact same issue here!!! I have other wordpress installations for different domains at the same web host and none of the others have this problem. I'm running 2.8.2 on the site now, and would love to be able to use automatic update, but can't. Manual updating is a big pain, especially since this "one" site is trilingual and actually uses three separate wordpress installations to manage the content.

    ALL of the installations relating to this domain are experiencing the same problem. This makes me wonder whether it might have something to do with a setting in the htaccess file or with file permissions or something like that. Since I just manually updated to 2.8.2 (I didnt realize that 2.8.3 would be coming out the very next day!), the installation should be pretty clean. I'm not using any plugins that are different from WP installations that I have working smoothly, so unlikely to be a plugin conflict.

    The only additional piece of information I can think of that might(?) have an impact here is that the language prefs for all 3 WP installations for this domain are set to French. The other WP installations i am managing are all set to English. Not sure what the relevance might be there, but just in case...!

    ANY TIPS OR HELP ARE VERY MUCH APPRECIATED!!!!!! Is this a bug? A hack? What is this?? Thanks in advance.

  5. ashiado
    Member
    Posted 4 years ago #

    Follow-up to my above message: I just triple checked that all my plugins were up-to-date and they are. I also tried deactivating all my plugins, logging out, then logging back in again: same issue. Then I tried changing the language preference in the config.php file from French to English -- no difference. I've double checked file permissions too.

    Anybody else out there having this problem or have a suggestion for a fix? It seems like a significant security issue, because if I didn't happen to have other WP installations going that DON'T have this problem, i probably wouldn't notice that WP had been updated, or any of my extensions for that matter, because no notification shows up...

    Thanks!

  6. ashiado
    Member
    Posted 4 years ago #

    I just came across this month-old thread on the topic, but the http.php fix proposed in it is not working in my case. Just FYI for anybody else who comes across this!
    http://wordpress.org/support/topic/278487?replies=38

  7. ashiado
    Member
    Posted 4 years ago #

    i tried the edit to the class-wp-upgrader.php suggested here: http://ocaoimh.ie/wordpress-mu-2-8-3/ but it still didn't work.

    I also carried out a manual upgrade to 2.8.3 on one of the three WP installations relating to this domain, and that didn't fix it either.

    Six hours later...big sigh. Time for a break. Help?

  8. ashiado
    Member
    Posted 4 years ago #

    Finally SOLVED by installing the Core Control plugin and then following the directions here: http://wordpress.org/support/topic/231500?replies=12#post-1168609

  9. balord
    Member
    Posted 4 years ago #

    I have two installs of WP running on two identically-equipped Lunarpages hosts. When I went to apply today's 2.8.4 upgrade, one install gave me the error, the other did not. I decided to finally figure this out for good.

    The problem for me is caused by lines 1276-1277 of the WP_Http_Curl request() method in wp-includes/http.php. I commented those lines out and threw in a line of debug code on line 1325 (after the curl_exec call)

    print_r(curl_getinfo($handle));

    and tested the cURL transport using Core Control. I found that my requests were simply taking longer than the timeout. I don't know quite why that would be, except to guess that the shared server of my one install must be really swamped.

    I fixed it by building myself a little plugin that adds an action for the 'http_api_curl' action called on line 1315.

    After enabling this fix, WP showed the 2.8.4 upgrade button on the Dashboard page, but the WordPress Development Blog and Plugins sections still showed timeout errors. So, I also looked further and added a filter to my plugin hack to catch and modify $r['timeout'] in the WP_Http request() method on line 237.

    Here's is my plugin code, which overrides all timeouts to a massive 15 seconds:

    //adjustments to wp-includes/http.php timeout values to workaround slow server responses
    add_filter('http_request_args', 'bal_http_request_args', 100, 1);
    function bal_http_request_args($r) //called on line 237
    {
    	$r['timeout'] = 15;
    	return $r;
    }
    
    add_action('http_api_curl', 'bal_http_api_curl', 100, 1);
    function bal_http_api_curl($handle) //called on line 1315
    {
    	curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, 15 );
    	curl_setopt( $handle, CURLOPT_TIMEOUT, 15 );
    }

    I recommend you make sure this does not cause any other issues for your WP install. If you know how to make this code into a plugin, then you are capable enuf to be responsible for any adverse fallout. :) I only know this solved my immediate problem while still maintaining cURL functionality.

  10. lozanno
    Member
    Posted 4 years ago #

    How how how how to apply these plugin code? Please more directions...

    Thanks in advance!

  11. davidvanr
    Member
    Posted 4 years ago #

    Hello, I have 5 sites at 1Dollar-webhosting all with the same problem and the tech support doesn't even answer their email.

    I tried the plugin described above (remember to enclose the code in a <?php (at the beginning) and ?> (at the end)

    and it doesn't work

    The plugin loads fine but I get the same timeout errors and Core Control shows an error on the cURL transport.

    HOW TO FIX THIS ERROR ?????????? My wp-o-matics are all stalled !!!

    Thanks for any expert's help out there !! (my hoster sure isn't going to help

    <?php
    /*
    Plugin Name: Curl Timod
    Version: 1.0
    Plugin URI: http://none
    Description: modify timeout vals
    Author: fix
    */
    //adjustments to wp-includes/http.php timeout values to workaround slow server responses
    add_filter('http_request_args', 'bal_http_request_args', 100, 1);
    function bal_http_request_args($r)
    {
    $r['timeout'] = 15;
    return $r;
    }

    add_action('http_api_curl', 'bal_http_api_curl', 100, 1);
    function bal_http_api_curl($handle) //called on line 1315
    {
    curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, 15 );
    curl_setopt( $handle, CURLOPT_TIMEOUT, 15 );
    }
    ?>

  12. balord
    Member
    Posted 4 years ago #

    Perhaps 15 seconds isn't enough timeout for you? Try setting it to something ridiculous like 100 and see if it works. Your blog will be slooooooow, and you'll want to change it right back to something practical, but if that doesn't work then the timeout isn't the cause of your problem.

    I think using Core Control, you can use a combination of the HTTP Access Module and HTTP Access Logger Module to figure out exactly how long the reponse time for cURL is taking. Try running the cURL "Test Transport" test in External HTTP Access. I did it once and I think that's how I arrived at 15 for my blog. Can't remember exact details right now tho.

  13. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Check with these steps:

    1) comment these lines from wp-includes/http.php file:

    curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, $r['timeout'] );
    curl_setopt( $handle, CURLOPT_TIMEOUT, $r['timeout'] );

    2) save this code in any .php file and upload it in plugins directory and activate it.

    <?php
    add_filter('http_request_args', 'bal_http_request_args', 100, 1);
    function bal_http_request_args($r) //called on line 237
    {
    	$r['timeout'] = 15;
    	return $r;
    }
    
    add_action('http_api_curl', 'bal_http_api_curl', 100, 1);
    function bal_http_api_curl($handle) //called on line 1315
    {
    	curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, 15 );
    	curl_setopt( $handle, CURLOPT_TIMEOUT, 15 );
    }
    ?>

    Thanks,

    Shane G.

  14. Spostare Duro
    Member
    Posted 4 years ago #

    Thanks Shane G. All seems to be working with your solution. Much appreciated. *-)

  15. Anton
    Member
    Posted 4 years ago #

    Hello,

    I read all posts above but I still don't understand how to get rid of this message in my Dashboard "WP HTTP Error: name lookup timed out".
    The issue occurred when I upgraded to 2.9.1.
    Could someone please provide me with a step by step explanation of how to solve this issue?

    Thanks a lot in advance.

    Anton
    http://www.doordebenen.nl

  16. datadoit
    Member
    Posted 4 years ago #

    What's interesting is that I followed the suggested fix above, and it fixed the problem. Then for grins I reversed out the changes expecting to break it again, and it's still fixed! I'll look into this further.

  17. simon686
    Member
    Posted 4 years ago #

    Hi,
    I'm with Anton on this one, a step by step guide as I don't feel confident enough to start messing with code. Apart from anything else, I have no idea where to begin looking for it.

    Also, thanks a lot in advance

    Simon

  18. Joco1114
    Member
    Posted 4 years ago #

    Thank you, its working for me! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.