WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Dashboard - Incoming links disappeared (16 posts)

  1. atelier455
    Member
    Posted 7 years ago #

    I've noticed today that on both of my WordPress blogs, the Recent Activity section on the Dashboard is missing the 'Incoming Links' info which usually shows at the top of this section. I've checked on Technorati and incoming links info is still available for both sites (www.joannatidball.com and http://www.atelier455.com)

    Has this happened to anyone else or could this be a result of something I've done to my blogs?

    Many thanks for your help.

  2. spencerp
    Member
    Posted 7 years ago #

    Don't feel bad, mine are too. =) It's a temporary thing, they'll be back again then. ;) That section is powered by: technorati.com

    spencerp

  3. Chris_K
    Member
    Posted 7 years ago #

  4. atelier455
    Member
    Posted 7 years ago #

    Thanks for the quick reply! Glad it's not just me :)

    Sorry for missing the existing thread - I did look for one but obviously not very well!

  5. spencerp
    Member
    Posted 7 years ago #

    You're welcome. =) Thanks Handy for that thread..I'll bookmark it.. =) I didn't even look for any threads, I just viewed my blog's admin quick, to see if mine weren't showing too.. ;)

    spencerp

  6. shetango
    Member
    Posted 7 years ago #

    This seems to have happened again, correct? I'm not seeing the Incoming Links section in my Dashboard today....

  7. rudolf45
    Member
    Posted 7 years ago #

    Seemingly, you don't see the topic titles here on the main page either. Or the search button...

  8. whooami
    Member
    Posted 7 years ago #

    anurism anyone?

  9. whooami
    Member
    Posted 7 years ago #

    just keep bumping them all the top, why not. ive seen worse bumps!

    I've stopped short of telling people that reinstalling your files helps :P

  10. saphod
    Member
    Posted 7 years ago #

    I have the same problem: no incoming links on the dashboard...
    (see this post on my website).

    Actually, they seem to have changed the URL to the technorati feed
    (see this post on the technorati support page).

    e.g.

    http://feeds.technorati.com/cosmos/rss/?url=http://saphod.net

    has become

    feed://feeds.technorati.com/search/saphod.net

    Does anyone know how to implement this into the WordPress files?

    The "Who Link Here" Plugin no longer works, either...

    Any ideas?

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Edit wp-admin/index-extra.php.

    Change this code (on line 10 or close to it):
    $rss = @fetch_rss('http://feeds.technorati.com/cosmos/rss/?url='. trailingslashit(get_option('home')) .'&partner=wordpress');

    to this:
    $rss = @fetch_rss('http://feeds.technorati.com/search/'. trailingslashit(get_option('home')));

    Personally, I changed my incoming links to use Google Blogsearch instead, as I think it gives better and more relevant results than Technorati. Just use this code:

    ...
    $rss = @fetch_rss('http://blogsearch.google.com/blogsearch_feeds?hl=en&scoring=d&ie=utf-8&num=10&output=rss&partner=wordpress&q=link:'. trailingslashit(get_option('home')));
    ...
    <h3><?php _e('Incoming Links'); ?> <cite><a href="http://blogsearch.google.com/blogsearch?hl=en&scoring=d&partner=wordpress&q=link:<?php echo trailingslashit(get_option('home')); ?>"><?php _e('More &raquo;'); ?></a></cite></h3>
    ...

    Obviously you need to replace both lines... if you don't immediately see what to replace, you probably shouldn't do it.

  12. Chris_K
    Member
    Posted 7 years ago #

  13. saphod
    Member
    Posted 7 years ago #

    Technorati seem to have fixed the error:
    http://support.technorati.com/topic/462

    Hmm... the WP-Plugin "Who Link Here" seems to be working again, but I still don't see the incoming links on the WP dashboard...

    I have tried to manually change the "index-extra.php", too, but it didn't work... maybe I messed up and should just upload the original file again.

    @Otto42:
    Thanks for the tip with Google Bloglines - I may give it a try. Is there any way of showing both Technorati and Google in the dashboard? Should be just copying the lines in index-extra.php, shouldn't it?

  14. saphod
    Member
    Posted 7 years ago #

    OK, I just re-checked...
    Everything seems to work fine again now.

  15. saphod
    Member
    Posted 7 years ago #

    OK, hopefully my last post here... :-)

    I've just tried Googe Blogsearch (not "...lines", sorry) and found out that but two links, every entry comes from my own site... so, I'm gonna stick with Technorati.

  16. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Well, perhaps that's telling you that you link to your own posts a bit too often. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic