WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Dashboard > Posts > displays no list of posts and doesn't let me add posts (5 posts)

  1. rjhayton
    Member
    Posted 5 years ago #

    From my Dashboard Posts > Edit doesn't display a list of my posts (over 600), all but one were just recently imported from my WordPress.com blog.

    Also, Posts > Categories doesn't list my categories, but Posts > Post Tags does list my tags. I can see a list of pages and add a page no problem.

    The problem with adding a page is that there is no box to type in. Quickpress will add one from the dashboard, but all I can do is delete posts. Here's a few screenshots that will help.

    Add post

    Edit Posts

    Categories

    Post Tags

    I just recently migrated my wordpress.com blog over to my new hosted site. I haven't deleted the wp.com blog yet, though.

    Thanks for any help I can get on this.

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Try deactivating all plugins and check to see if this resolves the problem. If it does, re-activate the plugins one by one until you find the problematic plugin(s).

    Also see:
    http://wordpress.org/support/topic/279132

  3. rjhayton
    Member
    Posted 5 years ago #

    The only plugins I have are inactive. And I'm using the default theme currently. I'll check out that topic. Thanks.

  4. rjhayton
    Member
    Posted 5 years ago #

    I've tried this from the above link: "3. Delete wp-admin and wp-includes directories and upload fresh copies from a new(important) install package or reinstall automatically". I also have no active plugins, but I'm still having the same problems.

    Can anyone help?

  5. rjhayton
    Member
    Posted 5 years ago #

    I finally figured it out. I saw some notes on my host's compatibility with new versions of WordPress at this link. Here is the note that I found: "1and1 (fails running PHP 4, but works with PHP 5. Add the line: AddType x-mapp-php5 .php to the file .htaccess in your main wordpress directory to enable PHP 5. This also appears to not only affect Core updates but some Plugin updates as well.)".

    I wasn't sure if I could do this, but I went into my 1&1 admin, to the explorer area where I could see the files, and found .htaccess. I downloaded it opened it with wordpad and wasn't sure where to add that line. I added that line at the very first space in the file before any of the code there. I saved it to my desktop but it saved as .htaccess.txt. I went ahead and deleted the .htaccess file at my site and uploaded the new file, then renamed it to .htaccess.

    Immediately all my problems went away. Not only those mentioned here, but I had a few .xml (wxr) files I couldn't get to import properly and they magically did.

    Wanted to share my fix for the benefit of all.

Topic Closed

This topic has been closed to new replies.

About this Topic