WordPress.org

Ready to get started?Download WordPress

Forums

Dashboard disappears plus no RSS - Help please! (7 posts)

  1. penguinelk
    Member
    Posted 3 years ago #

    So, I posted yesterday because my dashboard wasn't appearing at all. At one point, my blog itself was nothing more than a blank screen either. Thankfully, I was able to go through my web host and update WP to 3.0.2. My dashboard appeared again though my blog and dashboard were not functioning correctly. I weeded out and deleted a bunch of plugins (I hadn't changed or added anything in quite awhile and had no issues until just now).

    In the whole process, I discovered that there is no rss feed for the blog. I had feedburner when I was with blogger and thought I had moved things correctly only to find myself stuck in what I thought was a loop. I looked into it and cannot find an rss or atom.php file anywhere and it does not validate with feedburner. Here's the error I got:

    Sorry

    This feed does not validate.

    line 1, column 1: Blank line before XML declaration [help]

    ^
    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

    Feeds should not be served with the "text/html" media type [help]

    Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

    line 353, column 0: content:encoded should not contain object tag [help]

    <p>The Halleluja Chorus is a favorite of mine. I have great memories of lea ...

    So, right now, I can use my dashboard, however, I cannot just click to delete a plugin. I must click the box and go to "bulk actions" to delete. After deleting, I get the blank white screen and need to hit the back button to see ANYTHING and then click Dashboard to refresh.

    I am at a loss. I am wondering if this is an issue with my theme possibly? I am using the free version of Platform by Pagelines. I tried to look at other themes through the dashboard but could not go forward past page 1 - the arrows and the page numbers do not work.

    Please help! I don't know what information might be helpful.

  2. stvwlf
    Member
    Posted 3 years ago #

    Hi

    The validation error is typically that there is a blank line at the top before the code in the feed starts. This causes Internet Explorer in particular to choke.

    Usually when there is a blank line at the top of the feed there is also a blank line at the top of the View Source code on the main site. Check View Source in a browser to confirm. If so it means something is wrong, or you have some bad code somewhere.

    The first place to look is in your theme's functions.php file to see if there are any blank lines at the very beginning or end of the file, outside of the opening and closing PHP tags - <?php at the top and ?> at the bottom.

    I also suggest you validate your site, not just your feed. Very often validation errors in the feed come from the same source as validation errors on the main site.

    The problems with the dashboard are probably not related to the validation issues however.

    Not sure it is related but try upping the memory allocated to WordPress. Open your wp-config.php file (in the root folder of your WordPress installation in a text editor, or if you don't have one, in the editor in your web hosting control panel.

    See if there is a setting like this in the file:
    define('WP_MEMORY_LIMIT', '64M');
    If there is not, paste that line into the file above the line near the end that says to stop editing here.
    If there is and it is set to less than 64, change it to 64.

    See if any of this makes a difference.

  3. penguinelk
    Member
    Posted 3 years ago #

    Thank you!

    I viewed the source and saw the blank line at the top. That probably explains the feedburner issues. I'll look into that later.

    I had Chrome freeze up this morning and had to force quit. I HAD been able to work in my dashboard until then. Now I just get a blank white screen again (though for the moment, my blog is still appearing). I checked the wp-config.php file and added the `define('WP_MEMORY_LIMIT', '64M');
    ` you suggested. That didn't change anything.

    Any other ideas? Could akismet be causing issues? I use intensedebate for comments and recently activated akismet after some suggestions to do so.

    My blog is rediscoveringdomesticity.com.
    Thanks!

    I am beginning to think I should have stayed with blogger....

  4. stvwlf
    Member
    Posted 3 years ago #

    Hi

    WordPress is a great product and far less limiting than Blogger. You are just having some initial setup problems that need to get ironed out.

    If you suspect the problem might be Askismet then start by disabling Askismet and see if that resolves the problem.

    The standard WordPress advice for problems such as yours is to temporarily switch to the default theme and see if the problems are resolved. If they are you know the problem is in your theme. If they are not, keep the default theme active and disable all plugins. See if that cures the problem. If it now works you know the problem is with one plugin, or with the way one plugin interacts with another plugin. Turn the plugins on one by one until you find the one that is causing the problem.

    Or, if you find it works with no plugins and the default theme, you could try switching back to your real theme and see if it works with no plugins. Same thing, turn the plugins on one by one checking each time until you find the one that is causing the problem.

    There are many plugins in the plugins directory that will not work with the current version of WordPress. Often people install plugins that haven't been updated in a year or two and they can cause problems. Or the combination of two plugins together can cause problems while either without the other works fine.

    I acknowledge it is frustrating to deal with such things. But they can be resolved.

    Most of the time when there is a blank line at the top of the View Source it means there are some code errors. When you can access your site's front end you should validate your HTML pages and as much as possible clean up your code. The most important errors to clean up are mismatched HTML tags. Usually a lot of the errors reported are minor and don't affect much. Mismatched tags can create problems, especially in Internet Explorer.

  5. penguinelk
    Member
    Posted 3 years ago #

    I will certainly try switching back to 2010 to see... whenever I can get to my dashboard again. Is there any way to disable a plugin from somewhere other than the dashboard? I just feel like I am stuck. Your advice has been great - I just don't know how to do any of it without a dashboard.

    I agree that wp is far superior to blogger - I'm just getting frustrated with all of my issues since moving over in November.

    Thanks!

    oh - here's a list of the plugins I currently have activated - I deleted any others yesterday:

    akismet
    all in one webmaster
    blogger to wordpress redirection
    dean’s permalink redirection
    do follow
    fast secure contact form
    html-javascript adder
    intensedebate
    online backup for wordpress
    topsy retweet

    I went into another site I am developing through WP to make sure this wasn't something with my computer. I had no problems there. I'm waiting for an open chat session with my web host in case there is an issue there, but their normal stance is that I need to check here on the wp forums or need to wipe everything clean and start from scratch with a new install.

  6. stvwlf
    Member
    Posted 3 years ago #

    My suggestion is temporarily move all of your plugins to a different folder. If you don't have an FTP program use the File Manager in your web hosting account.

    The location of WordPress plugins is in folder /wp-content/plugins. Either in FTP or the online file manager, create a new folder under wp-content called hold-plugins or temp or something similar. Then move the entire contents of the /plugins/ folder into that temporary folder.

    After you do, refresh your dashboard screen. Most likely it will start working again. Then move one folder at a time of plugins back from the temp folder to the /plugins/ folder, refreshing the dashboard each time. Most likely you will have to enable each plugin again in WordPress because WordPress will disable the plugin (keeping its settings) when it doesn't find the plugin's files in the /plugins/ folder.

    I doubt you have to start over again with your install. Just move and reenable the plugins one by one and most likely you will find the culprit.

  7. penguinelk
    Member
    Posted 3 years ago #

    Thank you! The suggestion of how to move the plugins in my files was quite helpful. I don't have things fixed, however, I discovered a problem with my web hosting (after much persistence that it wasn't wordpress's fault that I could not access my plugins folder (or ANY wpcontent folders for that matter).

    The issue has been escalated there and will hopefully resolve the dashboard issues. Once that is fixed, I'll move on to the rss troubles.

    Thank you so much for your time and help!

Topic Closed

This topic has been closed to new replies.

About this Topic