WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Group Email Subscription
Daily & Weekly Digests missing content (5 posts)

  1. Peter vanDoorn
    Member
    Posted 1 year ago #

    Fairly recently, after an update (can't remember what was updated though) members have been telling me that their Daily & Weekly Digests are coming through with no details of posts.

    Here's an example of what they see on the Daily Digest:

    ------------------------

    Your daily digest of group activity at Members’ Lounge
    Group Summary:
    (2 items)
    Group:
    To disable these notifications for this group click unsubscribe - change email options
    You have received this message because you are subscribed to receive a digest of activity in some of your groups on Members’ Lounge.

    ------------------------

    And here's the Weekly:
    ------------------------

    Your weekly summary of group topics at Members’ Lounge
    Group: weekly summary
    To disable these notifications for this group click unsubscribe - change email options
    How to follow a topic: to get email updates for a specific topic, click the topic title - then on the webpage click the Follow this topic button. (If you don\'t see the button you need to login first.)
    You have received this message because you are subscribed to receive a digest of activity in some of your groups on Members’ Lounge.

    ------------------------

    These are both tests which I ran with two posts made that morning. As you can see, the Daily Digest informs that there were 2 posts, but gives no details, while the Weekly gives nothing at all.

    I have checked in the View Queued Digest Items link and the posts are all listed for each user as you would expect, but obviously are getting lost when the actual emails are sent.

    Cheers

    http://wordpress.org/extend/plugins/buddypress-group-email-subscription/

  2. Peter vanDoorn
    Member
    Posted 1 year ago #

    Update landed today. Happy face.
    Didn't fix problem. Sad face.
    Obviously the developers are still alive, but they're choosing to ignore these posts. Even sadder face.

  3. Boone Gorges
    Moderator
    Plugin Author

    Posted 1 year ago #

    > they're choosing to ignore these posts

    We develop this plugin out of the goodness of our hearts. Cut us a little slack :)

    It's odd that you'd see different results when testing the queue than when when the email is sent. This is a hard problem to debug. I will try to look into it when I get a chance, but in the meantime if you've got any PHP skills, set up some debug breakpoints and report back if you find anything.

  4. HansRuedi
    Member
    Posted 1 year ago #

    24 hours ago I updated to 3.2.2 – now, no emails are sent out.

    I had to go back to 3.2.1 what is working for me.

  5. r-a-y
    Member
    Plugin Author

    Posted 1 year ago #

    > It's odd that you'd see different results when testing the queue than when when the email is sent. This is a hard problem to debug. I will try to look into it when I get a chance, but in the meantime if you've got any PHP skills, set up some debug breakpoints and report back if you find anything.

    Sounds like it could be a HTML -> plain-text conversion problem. GES has some conversion functions that could be intefering with this.

    Peter: can you verify what type of email you receive in your inbox? HTML or plain-text?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.