WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Cutting Off My Post in 2.3 (10 posts)

  1. Hillke
    Member
    Posted 6 years ago #

    I just installed WP 2.3 the other night. It seems that my posts are being cut off and replaced with ... I have no idea why it is doing this.

    Also, I am very familiar with WP and the live comment preview plug in. I had that plug in installed and working the other night, but now it has stopped working. Any suggestions to my two issues?

  2. Ivovic
    Member
    Posted 6 years ago #

    have you changed themes recently? - sounds like whatever theme you're using is displaying the post excerpt instead of the post itself.

  3. Hillke
    Member
    Posted 6 years ago #

    Well, I played around with the theme I had. how would I make it display the post and not the post excerpt?

    link : http://12string.org/wordpress

    Thanks!

  4. Ivovic
    Member
    Posted 6 years ago #

    on the relevant theme page, replace the_excerpt with the_content .. that should do it.

  5. Hillke
    Member
    Posted 6 years ago #

    I'm sorry, but I don't understand. What relevant theme page?

  6. Ivovic
    Member
    Posted 6 years ago #

    you said you were playing around with the theme? - was it index.php or another of the php files?

    If in index.php, find "the_excerpt" and replace with "the_content"

  7. Hillke
    Member
    Posted 6 years ago #

    The way the theme is set up, I was actually editing the header file. I have searched on index and the other php pages, but I can't find the "the_excerpt" section. Is there anyway you can view my source? I am sure that I am just blind, haha but this is driving me crazy.

  8. Ivovic
    Member
    Posted 6 years ago #

    no, that part can't be viewed when you 'view source' - it's part of the theme's php files which can't be viewed unless you're physically looking at the files themselves on your PC.

    It really does look like it's showing an excerpt, but perhaps its doing so via "the_content_rss" instead. Try looking for that in index.php, and replacing with "the_content" if you find it.

    Don't just 'view source' though - if you're doing that, you'll never find what you need.

  9. Hillke
    Member
    Posted 6 years ago #

    Thank you for your help!

  10. Ivovic
    Member
    Posted 6 years ago #

    you're welcome :)

Topic Closed

This topic has been closed to new replies.

About this Topic