WordPress.org

Ready to get started?Download WordPress

Forums

Customizing this Swatch theme... (28 posts)

  1. BMERadmin
    Member
    Posted 2 years ago #

    Okay guys, I've got my site set up at: http://www.ecoblu.zymichost.com

    WordPress installation went fine, insatllation of the free theme, Swatch, went awesome. Now, I'm just trying to customize it the way I need. Problem is, the theme does not come with any support.

    What I'm wanting to do, is to edit the areas on the homepage that say: 'Home', 'Portfolio Snapshots', and 'Hits from the Blog'.

    I figured out how to edit the 'Home' area, but the Portfolio Snapshots and Blog posts is just impossible to edit for some reason? Can anyone help out with this?

  2. egado
    Member
    Posted 2 years ago #

    They seems to be widgets... have you looked into Appearance > Widgets ?

  3. BMERadmin
    Member
    Posted 2 years ago #

    Wow, egado, thanks for the quick response. That was it! This theme is honestly AMAZING....

  4. egado
    Member
    Posted 2 years ago #

    Wish you a lot of fun with wordpress and your theme :)

  5. BMERadmin
    Member
    Posted 2 years ago #

    Thanks! and I also have another question...

    If you look at my site, do you see the line at the top of all different colors? Is there anyway to get rid of it? I'm guessing I should look in the CSS file?

    Please excuseme, I'm very new to CSS anddefiitely not an expert. So if you're about to give me some CSS instructions, please be fully explanable. Thanks =]

  6. egado
    Member
    Posted 2 years ago #

    1. childtheme
    If you want to make changes on the theme, you better create a childtheme of it http://codex.wordpress.org/Child_Themes otherwiese if your theme get an update, your changes may be lost... but if you want to try it out without a childtheme follow 2. :)

    2. Open the style.css and find

    #wrapper {
        background: url("images/wrapper-bg-colourstrip.png") repeat-x scroll left top transparent;
        padding-top: 5px;
    }

    3. Change it to

    /*
    #wrapper {
        background: url("images/wrapper-bg-colourstrip.png") repeat-x scroll left top transparent;
        padding-top: 5px;
    }
    */

    4. open blue.css and find

    #wrapper {
        background-image: url("blue/wrapper-bg-colourstrip.png");
    }

    5. change it to

    /*
    #wrapper {
        background-image: url("blue/wrapper-bg-colourstrip.png");
    }
    */

    so the colored line should disappear... let me know if it works you...

  7. BMERadmin
    Member
    Posted 2 years ago #

    Awesome, that should work, ill try it in a second. Im having another problem now =/

    When adding an image as a Slide, the image doesnt appear, and gives me this error when I right click>view image:
    A TimThumb error has occured
    The following error(s) occured:

    Could not create the index.html file - to fix this create an empty file named index.html file in the cache directory.
    Could not create cache clean timestamp file.

    Query String : src=wp-content/themes/swatch/images/iballbanner.png&w=900&h=338&zc=1&q=90
    TimThumb version : 2.8.10

    Any ideas?

  8. egado
    Member
    Posted 2 years ago #

    Could not create the index.html file - to fix this create an empty file named index.html file in the cache directory.

    try that ;)

    I have no other idea, don't know much about TimThumb... sorry :(

  9. BMERadmin
    Member
    Posted 2 years ago #

    TimThumb is giving me LOADS of errors...

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/www/wp-content/themes/swatch/images/iballbanner.png) is not within the allowed path(s): (VIRTUAL_DOCUMENT_ROOT) in /www/zymichost.com/e/c/o/ecoblu/htdocs/wp-content/themes/swatch/functions/thumb.php on line 861


    [ Repetative log entries removed. ]

    Anyone?

  10. I think that's something your host will need to address.

    Give this a read http://stackoverflow.com/questions/223800/how-can-i-relax-phps-open-basedir-restriction for an example of what I mean.

  11. anshulgoyal
    Member
    Posted 1 year ago #

    Hi, I am having the same problem
    I can't delete the "Portfolio Snapshots" and 'Hits From Blog'

    My widget area is also clear..
    Kindly help

  12. Shaan
    Member
    Posted 1 year ago #

    I know this topic is old, but I have found that instead of changing all of that code that @egado said to change, all you have to do is go into style.css and change the #wrapper padding to 0px. Doing it the other way messes up the home page.

  13. varunwordpress
    Member
    Posted 1 year ago #

    Hi Folks,

    I am also stuck in customizing Free Swatch theme for my Website.

    When I try to use portfolio option in it, it displays all portfolio images above content for the portfolio item in my website.

    I want to remove these automated pics above the title of my page (as below that i can include gallery and post pics at my preferred place). Please help me with some way to fix it. ?

    Thanks in advance.
    Varun

  14. aimsterct
    Member
    Posted 1 year ago #

    Varun, I am having the same problem as you regarding this theme. Seems looking at your link that you have succeeded in removing the automated photos above the images in a portfolio page. Can you let me know how you did that?

    Thanks in advance.
    Amy

  15. varunwordpress
    Member
    Posted 1 year ago #

    Hi Amy,

    Yes I did succeeded in removing the automated gallery pics on portfolio item page.
    For this, either modify below lines in style.css or add the same in custom.css (preferable, as this way you can easily manage the customizations).
    Note that below lines can vary from Swatch version to version, so prefer to copy similar looking lines from your style.css and copy it in custom.css and then modify width and height as 0 px in it.

    /* To disable automatic listing of gallery photos on portfolio item pages */
    
    body.single-portfolio #post-gallery, body.single-portfolio .post-embed, body.single-portfolio .video { float: left; margin-bottom: 0px; width: 0px; height: 0px }
    
    #post-gallery .pagination .jcarousel-prev, #post-gallery .pagination .jcarousel-next { cursor: pointer; width: 0px; height: 0px; position: absolute; top: 45%; }

    Hope it helps.

    Cheers,
    Varun

  16. spraveenitpro
    Member
    Posted 1 year ago #

    Hi

    I have a similar issue, the portfolio preview images are not loading for swatch portfolio page, when I open the developer console on chrome to debug this is the message :

    Failed to load resource: the server responded with a status of 400 (Bad Request) http://192.168.1.109/wordpress/wp-content/themes/swatch/functions/thumb.php?src=http://192.168.1.109/wordpress/wp-content/uploads/2012/09/apache.jpg&w=575&h=0&zc=1&q=90&a=c

    The screenshot is as follows :

    http://dl.dropbox.com/u/3779648/Screenshot%20from%202012-09-19%2022%3A45%3A44.png

    Praveen

  17. spraveenitpro
    Member
    Posted 1 year ago #

    Issue resolved , installed PHP-GD , this solved issue

  18. Cory Jaccino
    Member
    Posted 1 year ago #

    Did anyone ever figure out exactly how to remove the "Hits from the Blog" or "Portfolio Snapshots" sections? I've read that they are widgets, etc., but I can't figure out how to remove them entirely.

    I would prefer not to have them on the homepage and, whether I put the "Woo - Blog" widget there or not (with zero posts or not), I can't seem to get rid of it.

    The theme documentation says that this is controlled via a widget and BMERadmin seemed to have been able to figure it out with help from egado, but with no widgets in any of the three main columns, both "Hits from the Blog" or "Portfolio Snapshots" still shows up.

    Here is the site:
    bulletproofsearch.com (homepage)

    Any ideas? Thanks in advance! :-)

  19. Alex R
    Member
    Posted 1 year ago #

    Hi Cory,

    I'm quite new to WordPress (just started using it this weekend), but, was able to come up with a work-around to get the "Hits from the Blog" and "Portfolio Snapshots" off of the Swatch theme. The only issue is that an inch of the white space where they were remains, but, it's good enough for my needs without sitting down with someone that knows CSS better than I do to fully remedy the situation.

    I suspect that there is some buggy CSS code in there somewhere, and, with the absence of another widget in the Middle and Right body areas, it'll default to these two widgets. So, what I did, was drag and drop the Meta data widget into these two areas and leave the new widget completely blank. I bet that the CSS code for the blank Meta widget is overriding the defaults for the Hits from the Blog and Portfolio Snapshots pieces, and voila - no text, though, there is an inch of white space accounting for the "invisible widget".

    Not a perfect solution, but, good enough for my needs.

    Hope this helps,
    Alex

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a commercially-supported theme, you need to seek support from the theme's developers.
    http://support.woothemes.com/

  21. varunwordpress
    Member
    Posted 1 year ago #

    Hi Esmi,

    Thanks for reply. However I don't completely agree with you for the reasons stated below:

    --> I am using Free version of Swatch Theme by Woothemes which is equally liable to receive support in public forums as any other Free theme.
    --> Moreover, the issue I am facing might not be with the theme at all. Reason for that is, same feature (portfolio) is working for me for the portfolio items created before, but for all the new items I am creating now, in exactly the same manner as before, it is showing extra pics as in links referred above in my original post as well.

    Thus I feel the issue could be due to some of the new compatibility issues raised due to some other plugin or hosting server updates, if any, as well.

    If I can be assured that the issue is only due to theme, I might not expect a response here, but since the issue could be anywhere else as well (considering theme is showing correctly in old portfolio pages), I believe I deserve a reply/help/support from all my fellow wordpress mates.

    Hope now you can take a second look on my post and share your opinion on fixing the issue.

    Thanks in advance,
    Varun

  22. clarea
    Member
    Posted 1 year ago #

    I've been struggling with this too... and I offer up this solution which has worked for me but with a warning that I am a truly novice wordpress user!! I replaced the homepage widgets (middle and right) with the text widget (with no text /html put in text box) - and it seems to have done the trick. Hope that's useful.

  23. clarea
    Member
    Posted 1 year ago #

    Ideally I would like to stretch out the left home page 'recent posts' column so that it fills the screen (ie the blank area left by removal of the other widgets)... any ideas?! Thanks in advance.

  24. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a commercially-supported theme, you need to seek support from the theme's developers.
    http://support.woothemes.com/

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    And FWIW, WooThemes are listed on wordpress org as Commercial Theme Suppliers.

  26. jlwalker99
    Member
    Posted 1 year ago #

    Need a little help with this theme. I really like it but am having issues embedding youtube videos in the custom 'Portfolio' section. Images of the videos will appear on the homepage (and on a separate Portfolio page I created called "video" but clicking on them takes you to a 404 page saying the page doesn't exist.

    The site is located at http://www.kennywarrencomedy.com

    I have tried lots of possible solutions (including clearing the cache and uploading the latest Woo theme framework) but I think there's a code issue that I can't find. Any help would be most appreciated!

  27. Andrew
    Forum Moderator
    Posted 1 year ago #

    Rather than asking for help on a 6-month-old thread, create your own thread.

  28. jlwalker99
    Member
    Posted 1 year ago #

    FYI this is a free theme offered by Woo themes so I'm not able to take advantage of their support.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags