WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Customize/Live Preview not working (37 posts)

  1. nobeatenpath
    Member
    Posted 2 years ago #

    It will open the sidebar, but not my blog. Therefore not only can I not live preview anything, but also can not customize, including the theme I have been using for some time. It is almost as though it keeps looping when trying to contact my blog. Does anyone know what is going on?

  2. davey.leslie@gmail.com
    Member
    Posted 2 years ago #

    Same problem here. Different browsers, deactivating plugins... no effect.

  3. earth.chest
    Member
    Posted 1 year ago #

    Hi I am having the same issue as well. Did anyone resolve this?

    Everything was working fine and all of a sudden this issue started to occur. I don't know if it is due to the latest update as I keep my wordpress updated whenever it calls for it. I would really appreciate if someone could revert as this is causing a a lot of delay in my project.

    Thanks.

  4. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Problem persists under 3.4.2

  5. earth.chest
    Member
    Posted 1 year ago #

    Hi I solved the issue by doing the following:

    - Re-installed wordpress in my cpanel. that was the last resort for me as I had been running around in circles trying to deactivate even uninstall plugins, deleting media library, rolling back the wordpress versions and everything in between to no avail. After losing several precious hours over this, I finally decided to take the plunge as I was not getting anywhere anyway. So I uninstalled wordpress in my cpanel (I use Hostgator) and re-installed it. After that I re-uploaded my premium theme and everything was fixed.

    So if you are all still struggling with this issue, you may have to make a decision. Note that I did not risk much as my site was at its infancy. Therefore, for me it was the best route.

  6. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Yikes. Not worth it, I guess. But thanks.

  7. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    For what it's worth, this is what Live Preview is generating on my sites:

    <div id="customize-preview" class="wp-full-overlay-main"></div>

    An empty div.

  8. MarkSina125
    Member
    Posted 1 year ago #

    Can you please send a hint which this theme is from the same vendor or different.. because many a times they do have a tagged points where it clutches the plugin mode writes in admin editor.. which we can't see its a background process.. and yeah the version you shown here is very buggy!!

    Thanks!
    [ sig removed ]

  9. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Twenty Twelve, though same problem with Twenty Eleven

  10. Fee
    Member
    Posted 1 year ago #

    same problem here.
    Interesting: it works on my local server but not on the remote live site. Files and database dump are completely the same (except server path and tld of domains). There are php errors on the domain mapped subsites, but not on the main site (and there the customizer doesn't work, too, on remote server).

    Didn't want to reinstall yet, because I've a running multisite network. But I tried reuploading the WordPress core files (and deleting old ones first) from current version 3.4.2, I did a database dump switch to a new database. and of course first deactivating all plugins, switching between integrated (Twenty Eleven) and own themes. didn't help.

  11. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    I installed a clean copy with a new database and am getting the same empty div. I admin several sites though a dedicated server (jtlnet) running CentOS and the same problem exists for all of the different sites. I'm starting to wonder if this is a server-related issue. Don't really want to think about that... yikes.

  12. Fee
    Member
    Posted 1 year ago #

    Difference between my local and remote server:
    Local: Apache/2.2.22, PHP/5.3.15
    Remote: Apache/2.2.21, PHP/5.3.10
    I'm no server freak and remote on a managed server. Could you give me a hint where to look at?

    I compared local and remote page loading of customizer with firebug and phpinfo, using Twenty Eleven. In Memory Profile (firebug console) the local customize.php does 13167 calls, the remote only 10016 calls.
    I didn't work much with the memory profile before, it's a little bit hard to compare... If I sort by loaded files I can say that some files listet on local are not listet on remote. But in firebug Net everything is loaded ok.

    In addition I have to say, that I renamed wp-content. If you did that renaming, too, we could give that a deeper look if it could cause conflicts.

  13. Fee
    Member
    Posted 1 year ago #

    in class-wp-customize-manager.php the scripts are not enqueued.
    if I comment out this function (#684) or the belonging action hook
    add_action( 'customize_controls_enqueue_scripts', array( $this, 'enqueue_control_scripts' ) );
    on my running local install, the result is completely the same as on remote (empty div, missing scripts):

    public function enqueue_control_scripts() {
    		foreach ( $this->controls as $control ) {
    			$control->enqueue();
    		}
    	}

    I haven't seen this way of enqueuing in WordPress before. And it doesn't make sense why this should be differently handled by servers.
    I think I'll open a ticket maybe.

  14. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    I actually have no idea what could cause the empty div. Not a clue, and it's maddening because very few people seem to be experiencing this and the issue is way off the radar screen, it would seem. It makes no sense to my pointy little brain.

  15. Fee
    Member
    Posted 1 year ago #

    I hope to get insights on wordpress.org - maybe you want to join in the ticket, where somebody reported this as bug:
    http://core.trac.wordpress.org/ticket/22037

  16. Fee
    Member
    Posted 1 year ago #

    Hi Davey, could you please check this: The preview in customizer is working for me when using Google Chrome Browser. Maybe you're more advanced than me in javascript analysing and could check it. I think it's an jquery issue.

  17. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Chrome (Mac) is my normal browser. The issue is not browser specific for me.

    BTW, thanks for all the effort you're putting in on this issue.

  18. Fee
    Member
    Posted 1 year ago #

    Hi Davey, please look at the mentioned ticket, I posted my solution there. You can try this until the next version is coming out.

  19. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Bit confused.

    // Check for a signature in the request.
    index = response.lastIndexOf( signature );
    if ( -1 === index || index < response.lastIndexOf('<body>') ) {
    deferred.rejectWith( self, [ 'unsigned' ] );
    return;
    }

    // Strip the signature from the request.
    response = response.slice( 0, index ) + response.slice( index + signature.length );

    // Create the iframe and inject the html content.
    self.iframe = $('<iframe />').appendTo( self.container );

    is where? I didn't see it where I assumed you were pointing at.

  20. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    Ah... I found it (where you said it was, of course), but the fix you suggested didn't work for me. I tried the <body> fix first, then backed up to the //return. Thanks though. Seriously, your kung fu is better than mine!

  21. Fee
    Member
    Posted 1 year ago #

    I used the script debug, so the customize-controls.js was used by WP. Did you already used the body tag instead of html in the customize-controls.min.js, too? That's usually used by WP. Thanks! So let's keep on fighting ;-)

  22. anahata9
    Member
    Posted 1 year ago #

    So... I assume from the way this was left that there is still no solution to this?
    Everything was fine, then live preview stopped working. Left sidebar visible, but nothing in main window.
    All I can think that changed was I installed some new themes and activated Akismet. I have since deactivated Akismet (which means getting lots of spam now), but no change.
    I have opened it in Firefox and Chrome. Doesn't work in either browser.
    So sad... until this point I was so thrilled with WordPress.
    Now this major part of its functionality is disabled!!!
    If I uninstall and reinstall WordPress, what will be lost in the process? (anyway, I'm not sure it will make a difference based on comments above)

  23. Fee
    Member
    Posted 1 year ago #

    Hello anahata9, please look into the linked ticket on WordPress trac.
    For me nacins solution from this ticket works:
    http://core.trac.wordpress.org/ticket/22430

    ... try this one-line plugin on for size:
    remove_action( 'shutdown', 'wp_ob_end_flush_all', 1 );

    I won't suggest to make a new install now because WP 3.5 is coming out very soon!

  24. anahata9
    Member
    Posted 1 year ago #

    If possible, could you explain in terms a kindergarten child would understand. Where would I put that code?

  25. Fee
    Member
    Posted 1 year ago #

    :-) sure, sorry. I hope, my English will be understandable.
    First: Do you have access to your files per FTP? You will need this.

    Do you use an own theme? If yes you could put it in the functions.php

    If not do this:
    Open a text editor like notepad and put this into it:

    <?php
    /*
    Plugin Name: My Custom Plugin (any name you like..., must be unique)
    Author: Your Name
    Version: 1.0
    Description: Customizer Bug Solution (You can write what you want here)
    */
    remove_action( 'shutdown', 'wp_ob_end_flush_all', 1 );
    ?>

    Then save this file into your plugins directory: Look for "wp-content" inside your installation and there for the folder "plugins". Save the file into this folder (save it on your computer first and then load it up per FTP) and name it "mycustomplugin.php" (be sure that it doesn't have another suffix/ending and that this name is unique).
    O.k. Now open your WordPress site in a browser, login and activate the Plugin on your plugins page.

    Please give me feedback if you got it and if it's working for you!

  26. anahata9
    Member
    Posted 1 year ago #

    Thanks very much. Unfortunately, it didn't work.

  27. Fee
    Member
    Posted 1 year ago #

    in the last hour WordPress 3.5 has been released. Maybe you'll have luck with updating and / or making a new install now.

  28. anahata9
    Member
    Posted 1 year ago #

    Updated to 3.5. Still doesn't work. :(

  29. Fee
    Member
    Posted 1 year ago #

    ok, let's step back a bit.
    Did you try deactivating all plugins and switching to a default theme (twentyeleven for example)? Clearing cache?
    Do you have special configurations in your htaccess? Are you on a multisite install?
    Is it a live site or can you test a little bit?
    If it's live - can you give us the link?
    Did you try firebug yet?

  30. davey.leslie@gmail.com
    Member
    Posted 1 year ago #

    I just updated to 3.5 and still having the same old problems. I've tried everything suggested on the forum, and nothing. I still love WordPress, but this is annoying.

Topic Closed

This topic has been closed to new replies.

About this Topic