WordPress.org

Ready to get started?Download WordPress

Forums

Customised permalinks causing 404 error on Wamp. (2 posts)

  1. sarath005
    Member
    Posted 1 year ago #

    Hi!
    I am new to wordpress. I have installed wordpress on WAMP local server. I have customized my permalinks using %category%/%postname% code. And then if i try to open any page or post(except home page), it shows 404 error page not found. Please help me, i have been searching solution for this from last three days and did not find any .....

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    For enabling pretty urls / permalinks, you have to enable Apache mod_rewrite.

    1. Start WAMP Server. Click on the WAMP Server icon in the tray. Go to Apache -> httpd.conf link on the list. Click on that file link. It will open httpd.conf file in notepad.
    2. Use the Find / Search function in Notepad and search for this line :

    # LoadModule rewrite_module modules/mod_rewrite.so

    Remove that hash and a space before :

    LoadModule rewrite_module modules/mod_rewrite.so

    Save it. Exit.

    3. Restrat WAMP.

    Permalink will work.

    http://codex.wordpress.org/Using_Permalinks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.