WordPress.org

Ready to get started?Download WordPress

Forums

Codepress Admin Columns
[resolved] Custom User Fields return blank screen (5 posts)

  1. idstm
    Member
    Posted 1 year ago #

    When I add a user meta field to the Users list, and then try and sort, I get a blank screen. Nothing at all comes back.

    This is on WP 3.5, networked edition. I'm thinking it's the Networked Edition part that is breaking it. It works fine on a regular edition with the same settings.

    http://wordpress.org/extend/plugins/codepress-admin-columns/

  2. dmallon
    Member
    Posted 1 year ago #

    I am experiencing this same problem. Sorting by user-meta works on a standalone WP installation but returns no results in a multi-site installation.

    Thank you for any assistance you can provide.

  3. fried_eggz
    Member
    Posted 9 months ago #

    Same problem here. Any fix for this?

  4. fried_eggz
    Member
    Posted 9 months ago #

    This is a bug in the Codepress Admin Columns Pro add-on.

    In WordPress, user meta is stored in the wp_users table and not in wp_xx_table. On line 206 and 207 of the file cac-addon-pro\classes\sortable\classes\user.php:

    $wpdb->prefix should be changed to $wpdb->base_prefix

    Patch:

    Replace line 206 and 207 with
    $user_query->query_where .= " AND {$wpdb->base_prefix}users.ID IN ({$column_names})";
    $user_query->query_orderby = "ORDER BY FIELD({$wpdb->base_prefix}users.ID,{$column_names})";

  5. Tobias Schutter
    Member
    Plugin Author

    Posted 9 months ago #

    Hi fried_eggz, thank you for the fix, I have included it in the next release v1.0.5, which should be available now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.