WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] custom upload folder (5 posts)

  1. Cammy_WP
    Member
    Posted 3 years ago #

    Ok the uploads folder, used to be working -
    just recently when i want to upload all stuffs on server - i did a final test on the localhost-

    it seems i cant upload any media aymore...

    it says
    " its parent directory writable by the server?"

    i made sure i put a custom folder directory in the settings of media...
    in the forum i read something about 777 settings?
    Where and how do I apply these? so it allows wordpress to write in that custom directory i created...?

    can someone explain please. i need to get this to work both on localhost and the real server..

  2. All about file permissions in WordPress:

    http://codex.wordpress.org/Changing_File_Permissions

    I reccommend you use an FTP client to change permissions on your remote web server.

  3. Cammy_WP
    Member
    Posted 3 years ago #

    that is way too much at the moment : /
    1. wordpress didnt make any .htaccess file
    2. used to had wp-content/uploads
    3. in settings change it to root/uploads

    after it was not working - so delete what i had modifed and left it blanc so wordpress uses wp-content/uploads

    after that nothing seems to working anymore...

    and read the file permissions, where do i add and what am i gonna add??? is way to complicated

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  5. Cammy_WP
    Member
    Posted 3 years ago #

    Ok solved this.

    For any who is using MAMP Pro and u need file permission of WordPress for your uploads folder.
    Go to HOST Tab - and click your localhost - there you find a button with **permissions**.
    set Owner and Group to www and enable it with set.

    In wordpress - under media settings, change your current folder to where ever you want. example: ../uploads this goes right direct in the root/uploads. click on save and you are done and all should work.

    For Filezilla when your site is online. Once you connected, rightclick on the upload folder and change the permissions there.

    Thats it. 1 min work >< took me half a day of research. And most anwsers on forums/posts etc are way too complicated.

    This is the quickest and best way using Mamp pro and Filezilla.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags