WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom theme options not available for users in multisite (8 posts)

  1. LanceGrigsby
    Member
    Posted 3 years ago #

    I have a couple of themes in my multisite installation that have custom options--problem is, those options only show up for me, the main site admin, but not for my users. Specifically, the two themes are iNove and Arjuna X. Any ideas out there?

  2. LanceGrigsby
    Member
    Posted 3 years ago #

    Andrea,

    Thanks for the tip. However, found this:

    add_theme_page(__('Arjuna Options', 'Arjuna'), __('Arjuna Options', 'Arjuna'), 'edit_themes', basename(__FILE__), 'arjuna_add_theme_page');

    and changed it to this:

    add_theme_page(__('Arjuna Options', 'Arjuna'), __('Arjuna Options', 'Arjuna'), 'edit_themes_options', basename(__FILE__), 'arjuna_add_theme_page')

    but no dice. Bounced Apache just to cover my bases, but still can't see the options page as a regular user.

  3. Then pick a lesser role until it does.

    http://codex.wordpress.org/Roles_and_Capabilities

  4. LanceGrigsby
    Member
    Posted 3 years ago #

    Andrea, not sure I follow ...

  5. David Sader
    Member
    Posted 3 years ago #

    Try cap "edit_theme_options" not the typo "edit_themes_options" you have above.

  6. LanceGrigsby
    Member
    Posted 3 years ago #

    Yup, that's the ticket. Type-o. Thanks for catching that, David!

  7. fredbiggar
    Member
    Posted 3 years ago #

    Not sure how to delete posts so I just blanked this out. The above suggestions work for inove.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags