WordPress.org

Ready to get started?Download WordPress

Forums

Custom Theme Float Issue With Permalinks & The_Content (1 post)

  1. Dan Clark
    Member
    Posted 2 years ago #

    Hi,

    I have developed a WordPress theme which was working fully. When I've updated to 3.4.1 my theme has remained the same but developed and annoying problem with some permalinks and divs with the_content tag in.

    I'm experienced in developing html templates in WordPress and have never experienced this problem before. It appears that in certain parts of the theme the top 200 - 400 pixels is un-selectable which causes permalinks to stop working and I'm unable to select text that the_content function displays.

    I have singled out the problem to the fact that my master content wrapper is somehow causing this issue. The content wrapper is setup to be a fixed width and a auto height which subsequently has auto margins left and right to center the div in the browser. When you float the tag left or apply a inline-block function the problem is fixed but obviously the layout is ruined.

    If anyone has a solution to this it would be much appreciated and I'm either missing something simple from being stuck staring at it or this is a problem with the new WordPress update.

    The problem div settings are as follows:

    #content {
    height: auto;
    width: 1000px;
    margin-top: 10px;
    margin-left: auto;
    margin-right: auto;
    position: relative;
    }

    The full website layout is working and there are no broken divs or missing tags. It seems the problems only arrive when a permalink or the_content is called into action.

    Any help much appriciated, pulling my hair out!!

Topic Closed

This topic has been closed to new replies.

About this Topic