Ready to get started?Download WordPress


Gravity Forms + Custom Post Types
custom post with GF forms does not post as logged in user (2 posts)

  1. Earthman Web & Media
    Posted 1 year ago #

    Hi, love the plungin, am having trouble getting it to post using the logged in user as author however...

    I have the "Use logged in user as author" checked:

    And I have selected "Require user to be logged in" for the form settings:

    But whenever the form is posted by a logged in user, it still defaults to the Admin user, who is set in teh dropdown as the default (cannot remove that)

    Is there perhaps a custom capability required? Or something I am missing? Please advise....


  2. Earthman Web & Media
    Posted 1 year ago #

    Ahhah!!! As soon as I assigned the edit_posts capability to that User's role, it worked!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic