WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Post Type UI hijacked my Home page (11 posts)

  1. parisvega
    Member
    Posted 4 years ago #

    I used Custom Post Type UI to create the custom type "Products". After creating a few products, I deleted the Products post type. I did not delete the posts I had created under products. (Looking back, I probably should have)

    The problem is that my home page is now redirecting to one of the old posts that were created under products. Here's what I've done to try and fix it:
    1. Flushed permalink settings by going to permalinks and saving.
    2. I went into the database and deleted the post from wp_posts.

    It's still hijacking my home page. Any suggestions?

  2. parisvega
    Member
    Posted 4 years ago #

    3. I also recreated the custom type type with the same name "Products" in hopes that the stray post would show up and I could delete correctly. Didn't work

    4. I then created a new post with the same name as the old post and then deleted it using the Custom Post Type UI admin. Didn't work.

    So... now my client's site: http://www.tlsignaturesalon.com/ is redirecting to a 404 page with this URL http://www.tlsignaturesalon.com/products/test-product-1/

    Thanks for any help you guys and gals can provide.

  3. parisvega
    Member
    Posted 4 years ago #

    5. I've deactivated all my plugins and now the home page is back.

    6. I'm now reactivating each plugin to see which one is breaking the home page...

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    I'd be interested to hear which plugin is the culprit...

  5. parisvega
    Member
    Posted 4 years ago #

    Redirection was the culprit.

    I went to the plugin settings for Redirection and tried turning off the monitoring of modified posts. That didn't work, so I clicked the delete button at the bottom of the page that clears all of Redirection's logs.

    With the Redirection plugin now deactivated my home page worked.

    I then reactivated Redirection and it still works.

    I guess there were some busted logs in Redirection that were breaking the home page.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    That's interesting. It's certainly not the type of plugin I'd have suspected. Thanks for the details.

  7. parisvega
    Member
    Posted 4 years ago #

    You're very welcome.

  8. bjornsennbrink
    Member
    Posted 4 years ago #

    I second that Redirection is to blame. I had the same problem on a client´s site a couple of weeks ago and simply deactivated Redirection - problem solved.

  9. Snow
    Member
    Posted 3 years ago #

    I've had a similar problem with Redirection and the "WP Boilerplate Shortcode" plugin. I think maybe Redirection doesn't play well with others. For now I've turned it off, since I need the other plugin much more.

  10. idealien
    Member
    Posted 3 years ago #

    There are several threads on the support forum like this mentioning that Redirection is either not playing nice with other plugins or causing very unexpected behaviour with default settings when used in isolation.

    I just found a similar situation with a self-built custom post type / redirection issue where creating a new post entry would redirect my landing page to that. Big bad to say the least.

    Disable this plugin!

    I have a hard time believing that the author has thoroughly tested the plugin to say that it works with wp 3.0.1 which the compatability stats indicate it does.

  11. John Godley
    Member
    Posted 3 years ago #

    Custom post types were causing the plugin to auto-redirect. This should be fixed in 2.2.29.

    As I wasn't using custom post types on my own site I did not experience the problem myself.

Topic Closed

This topic has been closed to new replies.

About this Topic