WordPress.org

Ready to get started?Download WordPress

Forums

Custom post type menu_order quick edit bug? (7 posts)

  1. boykenan
    Member
    Posted 2 years ago #

    Updated to 3.3. I've registered some custom post types, and when I choose "Quick Edit" from the "All [custom]s" screen, all menu orders register as 0, no matter what the order value actually is. Thus if I save any changes, the menu order for that post is reset to 0, wreaking havoc on the site's front-end.

    I tried disabling plugins and believe this to be a WP bug, but thought I'd check to see if anyone else was having the problem before troubling our noble core programmers with it.

  2. jadkison
    Member
    Posted 2 years ago #

    I can confirm the same bug in 3.3.1. If you use the quick-edit mode on custom post types - the order field input has the value changed to 0 no matter what the actual value is in the database.

  3. oan
    Member
    Posted 2 years ago #

    I also confirm this bug. Is this described in trac?

  4. hodgeman
    Member
    Posted 2 years ago #

    Discovered the same issue

  5. oan
    Member
    Posted 2 years ago #

    What I can understand it doesn't work when hierarchical=false

  6. Ivaylo Draganov
    Member
    Posted 2 years ago #

    Yes, I also ran into this issue. There are two relevant trac tickets:
    http://core.trac.wordpress.org/ticket/19911
    http://core.trac.wordpress.org/ticket/18352

    And according to trac this issue is fixed in 3.4

  7. DrLightman
    Member
    Posted 2 years ago #

    I'm glad a fix is ready for the next version.

Topic Closed

This topic has been closed to new replies.

About this Topic