WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type in WordPress 3.0 Menu (12 posts)

  1. enailor
    Member
    Posted 4 years ago #

    I have been playing with Custom Post types and the new features of 3.0.
    So far, I love what I am finding. However, I found something curious, and I can't figure out what happened.

    After adding a custom post type, I was able to add any of the custom post type postings to the new menu feature. I needed to start over, so I dumped the database and did a clean install. Now, with the same stuff, when I go to the Menu option, the custom post types are not showing as an option to include in the new Menu.

    I started the DB over because I was testing the difference in a custom post type as a 'post' vs as a 'page', which by the way I have seen no difference. But since starting over, I can't seem to reproduce the ability to add the new custom postings to my navigation menu, with the same settings as before.

    Anyone know the details on how to allow adding Custom Post Type postings to be added to the new Menu feature? Or what would block them?

    Thanks

  2. Make sure you have this in your register_post_type $args:

    'show_in_nav_menus' => true,

  3. kcssm
    Member
    Posted 4 years ago #

    I am having the same problem as enailor. I got it the first time but when I did it again with new database, it does not show in the navigation menu. Yes i have included
    'show_in_nav_menus' => true,
    but still not showing. Cannot figure out the error as the codes are just the same as before. Does anyone has any idea?

    Thanks...

  4. kcssm
    Member
    Posted 4 years ago #

    Ok its weired but I changed the name of the custom post type and it showed up in the navigation menu page. No idea, how this was solved just by changing the name. Any way, still waiting for the reason.

    Thanks...

  5. mixey
    Member
    Posted 4 years ago #

    I'm experiencing same problem :(
    Anyone figured out?

  6. mixey
    Member
    Posted 4 years ago #

    It looks like you just need to open Screen options and check checkboxes,
    Thanks to GhostPool for pointing this out.

  7. sabell2
    Member
    Posted 3 years ago #

    mixey - thanks for that would never have thought to look there!

  8. kumbi
    Member
    Posted 3 years ago #

    same poblem, but i'm using the recommended Custom Post Type UI plugin ..any ideas?

  9. kreviii
    Member
    Posted 3 years ago #

    Remember to go into your screen options and use the check-box and tick off your custom post type. It's a tricky one to remember... kinda like having to go the 'permalinks' settings page once registering a new post type — hidden tricky wp boobie-traps

  10. ignitionmedia
    Member
    Posted 3 years ago #

    kreviii, your a genius! didnt have it ticked!

  11. umarglobal
    Member
    Posted 3 years ago #

    Thanks Kreviii!!

    For those of you who dont know where the screen options is
    http://en.support.wordpress.com/screen-options/

  12. raviraj
    Member
    Posted 3 years ago #

    hey mixey,

    Thanks.. Saved a lot of time.

Topic Closed

This topic has been closed to new replies.

About this Topic