WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Post Type in Parent Theme causing 404s (4 posts)

  1. juliecrl
    Member
    Posted 1 year ago #

    Happy Friday,

    I'm customizing a theme for a client from a theme they bought off of themeforest.net. I created a child theme, where all the customization is located.

    Here is the issue:
    There are several custom post types in the parent theme that work perfectly if you use the parent them. But as soon as the child them is activated, I get 404 errors.

    Some Notes:

    • I've flushed rewrite rules and changed and saved the permalink, but no help.
    • The parent theme's CPT shows in the admin backend, just not on the frontend.
    • I added a cpt to the child theme and it works perfectly.

    Any ideas????

    Thanks for your help!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a commercial parent theme, you need to seek support from the theme's developer/vendor. We do not support commercial themes here.

  3. juliecrl
    Member
    Posted 1 year ago #

    I understand. However, I know I'll see this issue again somewhere down the pike that is not necessarily linked to a specific theme or author.

    I just thought someone may have run across a quick tip along the way.

  4. juliecrl
    Member
    Posted 1 year ago #

    Issue fixed!

    Here's a tip for everyone dealing with other author's themes:
    Add the following code if there are custom post types in the parent

    add_action( 'after_theme_setup', 'child_after_theme_setup' );
    function child_after_theme_setup() {
        flush_rewrite_rules();
    
    }

    It'll save you a bunch of time and headaches.

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic