WordPress.org

Ready to get started?Download WordPress

Forums

Simple Page Ordering
[resolved] Custom Post Type column content disappearing (5 posts)

  1. kepjr
    Member
    Posted 1 year ago #

    Hi, I'm trying to use this plugin with MarketPress's "Product" custom post type.

    I have it working fine, EXCEPT that when Simple Page Ordering is enabled, it makes all the custom columns on my Products list disappear.

    When I check with FireBug, it looks like it's shows the first TD, but then adds a / before closing it & doesn't display any of the content with in the TD or the </td>

    For example:
    <td class="variations column-variations"/>

    Have you guys seen this before?

    http://wordpress.org/extend/plugins/simple-page-ordering/

  2. Jake Goldman
    10up Engineer
    Plugin Author

    Posted 1 year ago #

    Haven't seen this before. More significantly, Simple Page Ordering does nothing to alter or even interact with the custom columns. It only "reads" information in the rows via JavaScript. I've set up several post types with custom column, using custom code, without any issue with this plug-in.

    Almost certainly a peculiar bug with MarketPress's feature.

  3. cruxwireweb
    Member
    Posted 1 year ago #

    I have this bug too, and I am not using MarketPress. I am using a custom post type that I created.

    The bug arises when I add 'hierarchical' => true to the register_post_type arguments. It doesn't matter whether or not I have the post type set to support page_attributes or not, I get the bug either way.

    Here's a pastebin link to the relevant code, in case it's helpful.
    http://pastebin.com/es1C23i8

    I'm using WP 3.5.1 and a custom theme. In addition to Simple Page Ordering, I am using the following plug-ins:my custom post type plugin, Akismet, Better Internal Link Search, Broken Link Checker, Contact Form 7, Dynamic Widgets, JetPack, Lazy Load, Shortcode Exec PHP, TinyMCE Email Button, User Switching, WordFence Security, and Yet Another Related Posts

    I tried deactivating all my plug-ins except my custom post type and Simple Page Ordering, and this did not fix the problem.

    If I can give you any more info to help troubleshotot, just let me know.

  4. cruxwireweb
    Member
    Posted 1 year ago #

    Well now that I typed that all out... I discovered that I get this bug even if I am not using Simple Page Ordering. 'hierarchical' => true causes the custom columns to disappear regardless.

  5. cruxwireweb
    Member
    Posted 1 year ago #

    Woo-hoo, figured it out.

    Here's the relevant codex page: http://codex.wordpress.org/Plugin_API/Action_Reference/manage_posts_custom_column

    Basically, in the function you are using to populate your custom columns, the action you call needs to be manage_pages_custom_column, not manage_posts_custom_column

    I didn't take the time to really grok this, but I think the basic reason why is that posts are inherently designed to be sorted chronologically.

    Sorry this doesn't help you kepjr. Not sure you want to hack MarketPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic