WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type and Taxonomy Permalinks (12 posts)

  1. ascottmccauley
    Member
    Posted 4 years ago #

    I've been working with custom post types to separate the portfolio section of my website from my blog. I ran into a problem with the rewrite variables and permalinks.
    I set up a custom post type of 'portfolio' with a rewrite slug of 'portfolio'
    I set up a custom taxonomy of 'portfolio-category' with a rewrite slug of 'portfolio'

    domain.com/portfolio - shows all the portfolio post types using /portfolio.php
    domain.com/portfolio/%postname%/ - shows the individual post using /single-portfolio.php
    domain.com/portfolio/%portfolio-category%/ - shows all the "landscapes" for example using /taxonomy-portfolio-category.php

    I got the first two parts to work OK, but the taxonomy is throwing 404 at me.
    If I change the post_type rewrite to something else ('photo') then the taxonomy works, fine, but I would like them to share permalinks like the default posts can.

    Any help would be great, or if you know how this will play out with the final 3.0 release please share.

  2. ascottmccauley
    Member
    Posted 4 years ago #

    Next problem I found in the same topic is that both the domain.com/portfolio (/portfolio.php) and domain.com/portfolio/%portfolio-category%/ (/taxonomy-portfolio-category.php) are showing up as is_single().
    It would make more sense to be it to be is_category() or is_taxonomy() or something else.

  3. Rhand
    Member
    Posted 4 years ago #

    I have the same issues or at least similar issues. Made a custom type portfolio with posts with custom fields. Added a test post and the permalink for that post did not work. First it showed the raw user unfriendly url and the it threw me a 404 now as well. I know custom types take single.php as a standard template, but I read somewhere that can be adjusted. If I find that intel again I will post back.
    On top of that I cannot use the permalink button on the portfolio page. It just sends me to the permalink config page while I already have the permalinks running. Maybe I need a custom permalink setup now that I use custom types?

  4. Rhand
    Member
    Posted 4 years ago #

    Well I added rewrite = true to my registered post type and now permalinks work, but still give me a 404:

    register_post_type('portfolio', array(
    	'label' => __('Portfolio'),
    	'singular_label' => __('Portfolio'),
    	'rewrite' => true,
    	'public' => true,
    	'show_ui' => true,
    	'capability_type' => 'post',
    	'hierarchical' => false,
    
    	'query_var' => false,
    	'supports' => array('title', 'editor', 'author' )
    ));

    I will check http://somadesign.ca/projects/smarter-custom-post-types/ for some options custom post types apparently do not have..

  5. defade
    Member
    Posted 4 years ago #

    You need to refresh you permalinks...

    Simply go to your "Permalinks" page under "Settings" in your admin area - Click save just to be on the safe side, and it will rebuild your permalinks

    Then job done - refresh the page you were having 404 problems with

  6. Rindy Portfolio
    Member
    Posted 4 years ago #

    Defade, I have read this a lot but it's not working for me. Saving Permalinks is not refreshing/rebuilding my permalinks. Is there any situation people know of where this happens? This is on my localhost using Wamp server...

  7. Rindy Portfolio
    Member
    Posted 4 years ago #

    Oops... I guess typing out "localhost" and "wamp" triggered my memory. Permalinks wasn't working because I hadn't enabled the rewrite module on wamp. For those needing to do that: Check this post

  8. phillyone
    Member
    Posted 3 years ago #

    also your problem here could be that you have 'query_var' => false

  9. wrk
    Member
    Posted 3 years ago #

    @everybody: I got the same problem here...Did anybody find a proper solution(not flushing the rules..)??

  10. kevin
    Member
    Posted 3 years ago #

    Same for me, i've been trying tons of options, no chance so far. My only problem comes from the pagination, all works fine, mysite.com/post1, mysite.com/customposttype, mysite.com/page/2 but the mysite.com/customposttype/page/2 doesnt.

  11. JoeyBottle
    Member
    Posted 3 years ago #

    In my case it's the same as Kevin described. Please help us!

  12. kevin
    Member
    Posted 3 years ago #

    Found the solution for me; i had a custom post type named 'fotolog' and also a page named 'fotolog' to load those posts.

    More infos here and here.

Topic Closed

This topic has been closed to new replies.

About this Topic