WordPress.org

Ready to get started?Download WordPress

Forums

Custom permalinks working in http but not in https (10 posts)

  1. nemalh
    Member
    Posted 2 years ago #

    Hi All,

    We are facing issue using permalink in https. These work fine for http but we get 404 error page in https.

    We are using /%postname%/ in the Custom Structure of permalink.

    This issue does not come if we use Default common setting.

    Thanks,
    Neha

  2. RichardWPG
    Member
    Posted 2 years ago #

  3. Tim S
    Member
    Posted 2 years ago #

    Hi Neha,

    Do you have a SSL installed on your server? To use HTTPS you must purchase a SSL certificate. You may want to check out this link as well:

    http://wordpress.org/extend/plugins/wordpress-https/

  4. arunparihar85
    Member
    Posted 2 years ago #

    Hi Tim and Richard,

    Thannks for your support. This is Arun, I work in same team with Neha.
    Just to give you updates. We have SSL certificate already working on site. The site works on https. The only issue that we are facing is if we change the Permalinks from Default to Custom Structure, then https stops working for Pages/Blogs urls. Everything works fine with Default Permalinks.

    Regards,
    Arun

  5. arunparihar85
    Member
    Posted 2 years ago #

    Hi,

    Any updates on this.

    Regards,
    Arun

  6. nemalh
    Member
    Posted 2 years ago #

    Hi All,

    Please share us updates on the same.

    We have custom permalink working on http but not on https.

    What configurations etc can I check, any logs i can enable to know what exactly the issue is.

    Kindly update us as this is high priority issue for us.
    Thanks,
    Neha

  7. nemalh
    Member
    Posted 2 years ago #

    Hi,

    Please update us on the same.

    Thanks,
    Neha

  8. chewbacca91125
    Member
    Posted 2 years ago #

    Hi there, I was wondering if you've managed to fix this? I am having a similar problem.

    I had updated my links from http:// to https:// and now my website does not work. I am unable to login to the dashboard to change it back. Can you pls let me know how you fixed this.

    Thanks,
    Clarence

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

  10. nemalh
    Member
    Posted 2 years ago #

    Hi Clarence,

    Yes we were able to solve the issue in our case.

    It was due to

    In the vhost of each blog we have entries for secure and non secured areas under port 443 and 80 respectively as

    <Directory "/abc/htdocs">
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    DirectoryIndex index.php
    </Directory>

    Where AllowOverride was set to None instead of All for https so webserver was not able to recognize/read virtualhost for the given directory.

    Changing None to All solved the issue.

    Hope this will help in your case.

    Thanks,
    Neha

Topic Closed

This topic has been closed to new replies.

About this Topic