WordPress.org

Ready to get started?Download WordPress

Forums

custom permalinks won't work properly (2 posts)

  1. davidedante
    Member
    Posted 1 year ago #

    Hi everyone,

    I read the permalinks guide on wp and tried to set up my custom permalinks, but with no luck.

    I put wp on my own space in http://www.mydomain.com/site and set up wp to load the content on http://www.mydomain.com, as described here:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    (i am saying this just in case it can be connected to the problem described below)

    now i am using a custom theme which works with custom post type called 'portfolio'.

    i tried to get permalinks like this:
    http://www.mydomain.com/post-name/

    but selecting writing /%post-name%/ but i got:
    http://www.mydomain.com/site/portfolio/post-name/

    is there a way to get the following permalinks structure?
    http://www.mydomain.com/post-name/
    or, in alternative:
    http://www.mydomain.com/portfolio/post-name/

    thanks in advise!

  2. davidedante
    Member
    Posted 1 year ago #

    ok, I was back to Settings > General and set up properly the "Site address (URL)" from
    http://www.mydomain.com/site to http://www.mydomain.com, so now the path is http://www.mydomain.com/portfolio/post-name/

    still wondering anyway if it is possible to get the shortest permalink as: http://www.mydomain.com/post-name/

    suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic