WordPress.org

Ready to get started?Download WordPress

Forums

Custom permalinks not working, search not working, and losing my mind (3 posts)

  1. TheDesignerGeek
    Member
    Posted 5 years ago #

    Okay, so I have a site that I designed using RapidWeaver of the Mac, with WordPress powering the blog page. Everything's working fine, hip hip hooray.

    Then I decide to re-design the site since I just threw it up real fast and it's kinda blah. I still wanted the home page to be driven by WordPress, but I wanted a different page for the permalinked articles... essentially, I wanted a bunch of divs with snippets of articles from different categories, then a "more.php" page for the permalinked page. So I re-do everything, export all the files from RapidWeaver, and test it on my local MAMP server. Everything's working great.... the custom permalink structure of "/more.php?p=%post_id%/%postname%" works no problem. Groovy!

    So I go ahead and publish to my web host and.... permalinks are busted. I get the dreaded "No posts found that match your criteria." Crap.

    I re-read through all the docs. I turn off all my plugins. I delete and re-create .htaccess. No dice. Permalinks are still busted. Search is still busted.

    Scream. Resist urge to punch something.

    Google..... try some more things.... nothing.

    Scream again. Have a drink. Have a smoke. Try some more things.... nothing. Check the MAMP install to the host install, go through setting-by-setting..... identical. Check file permissions..... identical.

    So I reverted to my backup, and decided to post here to see if anyone can help.

  2. scribu
    Member
    Posted 5 years ago #

    So you're permalink structure is "/more.php?p=%post_id%/%postname%".

    Here is a proposed solution:

    1. Turn off pretty permalinks: set the permalink structure to default.
    2. In your WordPress folder rename index.php to more.php
    3. Set the Site URL option to yoursite/wpdir/more.php

    Or, you could just leave the file as index.php and set the Site URL to yoursite/wpdir/.

  3. TheDesignerGeek
    Member
    Posted 5 years ago #

    Okay, I tried that, and it's working... mostly.

    But now, instead of 404-ing, visitors are sent to the home page. (and yes, the .htaccess page is edited properly.) And I can't get permalinks to redirect, no matter which redirect plugin I use, or who's directions I follow.

    Further, if I change the permalink structure to custom, and set it to something as simple as the default structure:

    /?p=%post_id%

    Then it gives me:

    Warning: fopen(/baseurl/more.php/.htaccess) [function.fopen]: failed to open stream: Not a directory in /baseurl/wordpress/wp-admin/includes/misc.php on line 75

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 100

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 102

    Warning: fwrite(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 103

    Warning: fclose(): supplied argument is not a valid stream resource in /baseurl/wordpress/wp-admin/includes/misc.php on line 105

    This gets generated at the top of every page, both admin and public. Gah. Sorry for being such a n00b, but I'm not exactly familiar with the WP source yet.

Topic Closed

This topic has been closed to new replies.

About this Topic