WordPress.org

Ready to get started?Download WordPress

Forums

Custom Permalinks Errors - 500 & 404 Pages Shown (15 posts)

  1. dchiniuk
    Member
    Posted 4 years ago #

    Hi,

    I have recently installed the latest wordpress theme 2.9.1 to a new web hosting package (FastHosts UK). I set up the blog following the 5 minute installation added all my content and every was fine.

    I wanted to make sure that my URLs were SEO friendly so I went to custom permalinks and entered /%category%/%postname%/ and saved the changes. I visited my website and noticed that when I clicked any link on my site I got the 500 Internal Server Error page.

    I removed the .htaccess and the site reappeared before doing exactly the same once I clicked on another link. I contacted my hosting provider and they assured me that the package that I was using has the ability to handle wordpress.

    I have searched the web and tried all different things to get them to work inculding deleting and reinstalling WP on numerous occassions, populating content, not popualting content, changing .htaccess permissions, check mod_rewrite is on.

    I do not know what else I can do? Any ideas...?

    Help would be much appreciated.

    Thanks

  2. Samuel B
    moderator
    Posted 4 years ago #

    a link to site?

  3. dchiniuk
    Member
    Posted 4 years ago #

    Hi,

    My site is http://www.d7even.co.uk, it shoes 500 Internal Server Error

    A colleague of mine is using exactly the same hosting company and he is having no problems.

    http://www.ipodtouchapplications.co.uk/wordpress

    thanks

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Try deleting/renaming your .htaccess file.

  5. krielkippenboer
    Member
    Posted 4 years ago #

    Hi All,

    I've done some testing, and as far as I can see the Permalinks (partly !) fails in case the WordPress-adres (URL) differs from the Blogadres (URL).

    As soon as WordPress- and Blog address are the same, the Permalinks (completely !) work.

    As soon as WordPress- and Blog address differ, only the default Permalink (completely !)works, any other setting will cause problems.

    Please note Permalink settings only PARTLY fails !
    For example the links to pages are ok, the links to blogs fail.

  6. dchiniuk
    Member
    Posted 4 years ago #

    I have tried deleting, renaming and editing the .htaccess file. Still no luck.

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    Why are you trying to set up different urls for the Site and the Blog?

  8. dchiniuk
    Member
    Posted 4 years ago #

    I dont't understand what you are getting at? I have one website http://www.d7even.co.uk which is not working. The other site is a colleague's of mine that I was giving as an example.

    Website: http://www.d7even.co.uk

    Issue: Changing permalinks from default to custom turns up an error, which seems to be the .htaccess file.

    I have gone through all the other posts on here, and none have seemed to of fixed the issue.

  9. Samuel B
    moderator
    Posted 4 years ago #

    I've done some testing, and as far as I can see the Permalinks (partly !) fails in case the WordPress-adres (URL) differs from the Blogadres (URL).

    they can't be different unless you're doing this
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  10. krielkippenboer
    Member
    Posted 4 years ago #

    Hi Esmi and Samboll,

    >> Why are you trying to set up different
    >> urls for the Site and the Blog?
    Because I have a client which does not want my name in the URL.
    The blog address must be:
    http://www.poelika.nl
    The URL of the place where the blog really is:
    http://www.groenewilg.nl/poelika

    I have no other choice but making Site and Blog different,
    if not "groenewilg" will be in the URL.

    If I make Site and Blog different, and I open the
    page (www.poelika.nl) all is ok.
    But ... if I use some non-default Permalink setting, the first
    page shows (inside the Default theme !) an error 404.
    In the WordPress Classic 1.5 Theme there's some message
    something you're searching for cannot be found.

    Even stranger other topics show up ok (when clicked).

    >>
    >> they can't be different unless you're doing this
    >> http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    >>
    Yes, I have done this and followed those instructions.
    And I have done some testing.

    Anyway, as far as I can see, Permalinks really cause problems
    when Site and Blog are not the same. (in any case when
    using the "Default" and "CLassic" themes).

  11. krielkippenboer
    Member
    Posted 4 years ago #

    Hi all,

    I've done some re-testing, and couln't reproduce the problem for my own site.

    I will try to find out why the same setting causes problems for the other site (the http://www.poelika.nl site, see previous posting).

    To help dchiniuk and possibly others I give my settings and config files here. File .htaccess is copied to dot_htaccess.txt so other people can see it, the same for the index.php file which is copied to
    index_php.txt, see links below.

    Here's my setup, including links:

    ===== Settings =====

    === General ===
    WordPress address (URL) : http://www.groenewilg.nl/kkb/wordpress
    Blog address (URL) : http://www.groenewilg.nl/kkb

    === Permalinks ===
    Custom Structure : /%category%/%postname%/

    ===== Site Config Files =====

    === .htaccess file ===
    See: http://www.groenewilg.nl/kkb/dot_htaccess.txt

    === index_php.txt file ===
    See: http://www.groenewilg.nl/kkb/index_php.txt

    === Testing following actions: ===

    Action 1:
    Enter URL in address bar: http://www.groenewilg.nl/kkb/
    Result: Ok, first page shows

    Action 2:
    Click on "Boer's Blog" under Categories
    Result: Ok, blog shows

    Action 3:
    Click on Header ("Krielkippenboer" in blue/green panel)
    Result: Ok, first page shows

    Action 4:
    Go to link: http://www.groenewilg.nl/kkb/category/boerblog/
    Result: Ok, blog shows

    Hope this helps other's.

    Will do some testing for http://www.poelika.nl later today !

    greetings

    Krielkippenboer

  12. krielkippenboer
    Member
    Posted 4 years ago #

    Hi,

    I'm getting desperate about not working permalinks !

    First: I can get the Permalinks working for the following situation:
    WordPress address: http://www.groenewilg.nl/kkb/wordpress
    Blog address: http://www.groenewilg.nl/kkb/
    Permalink: Custom Structure: /%category%/%postname%/

    The .htaccess file can be seen at:
    http://www.groenewilg.nl/kkb/dot_htaccess.txt

    The index.php can be seen at:
    http://www.groenewilg.nl/kkb/index_php.txt

    So for above situation, all works, all is ok.

    But, for the following situation, Permalinks don't work:
    WordPress address: http://www.groenewilg.nl/poelika
    Blog address: http://www.poelika.nl
    Permalink: Custom Structure: /%category%/%postname%/

    In this situation I'm presented the Error 404 - Not Found (but only for the start page (main page), for the blog entries the Permalinks DO work !)

    Also as soon as WordPress and Blog address differ and I select Permalink in the Settings menu, I see two warnings at the top of the page !

    Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s).

    This warning is for wp-admin/options-permalink.php and for wp-admin/includes/misc.php.

    Because of this warning the .htaccess file is not changed automatically (I have to change it by hand which is ok).

    I've changed the get_home_path() function in the /includes/file.php file to return a hardcoded home path, the warnings disappeared, the .htaccess file was changed automatically, but this hack did NOT fix the Error 404 - Not Found problem for the main page.

    Please help, thanks in advance.

  13. Samuel B
    moderator
    Posted 4 years ago #

    open_basedir restriction in effect.

    this is a host security feature - ask them what you need to do to allow what you want to do
    looks like a tmp folder needs to be moved or created

  14. krielkippenboer
    Member
    Posted 4 years ago #

    Hi Samboll,

    First of all: I will leave the problem visible on the site for a while.
    See: http://www.poelika.nl
    You will see the Error 404, but if you click the header Poelika, the article appears !
    Also all the other articles are ok, and Permalinks are ok, it's just the start-page which shows the problem.

    About the Warnings (due to Host Security)

    I didn't manage to fix the open_basedir restriction, so I moved the site back to its original place.
    This is: http://www.groenewilg.nl/poelika/wordpress

    The open_basedir restriction problem does NOT occur when WordPress-adres (URL) and Blogadres (URL) are the same !

    So, after setting those addresses to the same URL (www.groenewilg.nl/poelika/wordpress) I can go in the Permalink menu without the warnings !

    Then: I change the Permalink settings to:
    Custom /%category%/%postname%/

    Now something VERY strange happens !

    The .htaccess file in the wordpress directory is changed !
    (not the .htaccess fike in the poelika directory !)

    To make matters visible I changed the names of the files so you can have a look at them.

    See:
    http://www.groenewilg.nl/poelika/dot_htaccess
    http://www.groenewilg.nl/poelika/index_php.txt

    http://www.groenewilg.nl/poelika/wordpress/dot_htaccess

    I also copied the .htaccess which is in /poelika/wordpress to /poelika to give it a try: no luck.

  15. maalu
    Member
    Posted 4 years ago #

    Hi dchiniuk,

    It seems that the rewrite-module in the Wamp Server is't turned on. Please contact your server provider to resolve this.

Topic Closed

This topic has been closed to new replies.

About this Topic