WordPress.org

Ready to get started?Download WordPress

Forums

Custom permalinks don't want to work at all (6 posts)

  1. Unbelieva
    Member
    Posted 2 years ago #

    Hello!

    Again I'm getting this error:
    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    Last time I fixed this it took me a day and now I don't remember how I did it. I have put the .htaccess file with the mod_rewrite rules in all kinds of directories and put the permissions on 755, even 777. It's not working and I need to get these links working normally ASAP.
    I'm trying to get the permalinks to look like this: /%category%/%year%/%monthnum%/%postname%/

    P l e a s e help!

    Best regards,
    Unbelieva.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    The .htaccess file needs to be in your root WordPress folder.

  3. Unbelieva
    Member
    Posted 2 years ago #

    This did not help. I have the .htaccess file in the root WP folder with the permission 755 and with the following content:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Please help..

  4. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Check with your hosts that mod_rewrite is running on your server. And please don't start new topics on the same subject. All duplicated topics are deleted on sight.

  5. Unbelieva
    Member
    Posted 2 years ago #

    I already checked with my host before posting here (because usually they know how to easily fix these things). But this time they just said that the .htaccess file should be with the permissions 755 and nothing else.

    I just can't remember how I fixed this the last time and I need to get the permalinks working normally as fast as possible.

    Help desperately needed!

  6. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Then go back to them as your.htaccess file is correct.

Topic Closed

This topic has been closed to new replies.

About this Topic