WordPress.org

Ready to get started?Download WordPress

Forums

Custom Permalink Structure Not Working (10 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    Hi there!

    I'm using the latest WordPress 2.6.
    I migrated from Movable Type, and would like my permalink structure to be like this: /%year%/%monthnum%/%postname%.html, (as in 2007/10/what_am_i_up_to_lately.html)

    When I go to Settings -> Permalinks, choose the above as my Custom Structure and save the changes, none of the posts, pages (About), archives, comments etc. are accessible (always get a 404 error). Only the Default setting works for me (i.e., http://www.bsreview.org/blog/?p=123).

    Can anybody help me, please? Here is the site: http://www.bsreview.org/blog/. Thanks a lot for any help, and sorry if this has been dealt before. I searched but could not find anything on this specific problem.

  2. Anonymous
    Unregistered
    Posted 6 years ago #

    I have the same problem! Nothing works!

  3. lozy
    Member
    Posted 6 years ago #

    did you upload the .htaccess file to your blogs' root directory?

  4. scrstudios
    Member
    Posted 6 years ago #

    I followed the advice in another post and added the following under Settings>Permalinks and it seem to fix the same problem for me:

    1) Set Category base to "/category"
    2) Set Tag base to "/tag"

    Hope that helps

    Steve

  5. Anonymous
    Unregistered
    Posted 6 years ago #

    I found it! I used this plugin:

    http://www.askapache.com/htaccess/rewriterule-viewer-plugin.html

    Then i edited the .htaccess like this: (default but was missing)

    1.# BEGIN WordPress
    2.<IfModule mod_rewrite.c>
    3.RewriteEngine On
    4.RewriteBase /
    5.RewriteCond %{REQUEST_FILENAME} !-f
    6.RewriteCond %{REQUEST_FILENAME} !-d
    7.RewriteRule . /index.php [L]
    8.</IfModule>
    9.# END WordPress

    Now /%whatever% works

    :)

  6. Anna99
    Member
    Posted 6 years ago #

    can someone help me with this? i need to upload or modify my .htaccess file, and have downloaded the plugin that dikozall suggests. when i'm in the Options Configuration Panel of my WordPress and click "Go Edit" link, it give me the "Not Found" error. so what do i resolve this? i need to upload or somehow that file.

  7. Rooster
    Member
    Posted 5 years ago #

    Here's what I did that worked for me.

    1. Ensure that your .htaccess file is writable in your blog root directory. The permission should be set to "777". For MAC users, right-click and select 'Get Info'. The dialogue box should have an Octal value of 777 giving read, write and execute permissions to all 3 groups - User, Group and World.

    2. I had to put /index.php before the rest of my custom code in SETTINGS --> PERMALINKS in the WordPress control panel. It looked like this: /index.php/%year%/%monthnum%/%postname%/

    I don't know why or how that worked. I don't care. It works now. Hope it does for you.

    =]

  8. galleryuccs
    Member
    Posted 5 years ago #

    I have also been having ongoing problems with custom permalinks...

    Last year the galleryuccs.org site couldn't find post image links, but then it could if you changed the date for the post. Seemed like an odd work-around to me, but easy enough.

    Then, the 2009 folder I made that has this year's images for shows was and still is impossible to find by wordpress.
    The site uses the custom link formula of %category%/%year%/%postname%.

    Any ideas would be appreciated, I can't find anything in the forums or on the web that addresses this particular problem.

  9. galleryuccs
    Member
    Posted 5 years ago #

    Also, on the post I'm trying to make where only name of the post's text shows up instead of the image, I copied the image location, and for the thumbnail it used the 2008 folder, and for the full-size it used the 2007 folder.

    A little puzzle for your Monday!
    Thanks again, Millie

  10. peiferus
    Member
    Posted 5 years ago #

    The anonymous post listed above worked perfectly for me. I'm re-posting the contents of the .htaccess file here WITHOUT the line numbers (1. 2. 3. etc.). The code won't work with the line numbers included.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic