WordPress.org

Ready to get started?Download WordPress

Forums

Custom Permalink Structure for a completely Static Site? (18 posts)

  1. NixDesign
    Member
    Posted 6 years ago #

    I'm creating a site and using WP as a CMS. I have no categories, archives or posts, my site consists of pages and sub-pages only.

    In order for my page URL's to appear normally (not like /?page=14), I need to set my permalinks up so they can appear like .../page/sub-page.

    To the best of my knowledge the codex only mentions permalink structures like /%category%/%postname%/ but it also mentions many times how pages are different to posts, and I don't know how to structure my permalinks for a completely static site.

    I've had WP crash on me several times while trying to figure out this permalink issue so I would like to know for sure what to type into the "custom" box on the Options>>Permalinks page on the dashboard.

    For instance, is /%pagename%/%sub-pagename%/ acceptable?

    I have a .htaccess file sitting there with permissions set correctly just waiting for WP to do it's thing, and mod-rewrite is also enabled.

    Anyone?

  2. tsguitar
    Member
    Posted 6 years ago #

    I believe that WordPress uses something like /pagename/subpage by default for pages. That pagename is equivalent to %postname%. Have you tried this yet? What's a URL for one of your pages right now? Maybe this is already working how you want it to.

  3. moshu
    Member
    Posted 6 years ago #

    For instance, is /%pagename%/%sub-pagename%/ acceptable?

    If you read the Codex Using_Permalinks > you would know exactly what the structure tags are:
    http://codex.wordpress.org/Using_Permalinks#Structure_Tags
    No need for guessing.

    And as tsguitar said - any permalink structure which is not the default... will create for you the example.com/page/subpage type permalink.

  4. NixDesign
    Member
    Posted 6 years ago #

    With all due respect to you as a moderator Moshu, not everyone who posts questions on these forums does so on a whim.

    I have read that "using Permalinks" page time after time and still find it difficult to understand. I have searched these forums using search words such as "permalinks", "pages", "sub-pages", "htaccess" and "pagename" and many combinations of these together.

    I simply don't need to be told to read something AGAIN that is not written clearly.

  5. tsguitar
    Member
    Posted 6 years ago #

    Did you even look at what I wrote? I think your site is already doing what you want it to do.

  6. NixDesign
    Member
    Posted 6 years ago #

    Thanks TSGuitar,

    It's not actually doing as I want, at the moment it's just showing the opening page and if I type in /blog/accessibility or /blog/site-map etc, it just refreshes the opening page. If I type in /blog/?page=6 I start to see the other pages that I've put there (I've only put the top level menu pages in so far, no sub-pages yet).

    I'll try changing to something other than default like Moshu mentioned, and if that works then great. Is that what you're saying too?

    Moshu, I understand that many people just post without reading anything and don't even respond to the people who respond to them. I understand your frustration as a moderator but please believe me that not everybody is like that.

    I do believe that the WP codex is quite poorly written for a program that is so standards compliant. There are too many links within the text and the whole codex thing should rreally be divided into two as there are two distinct users of WP - Bloggers and Designers using it as a CMS.

    Anyway, I hope I haven't offended anyone too much.

    I'll try now and report back.

  7. moshu
    Member
    Posted 6 years ago #

    and Designers using it as a CMS
    ...and they should do their homework since usually they are paid for it. Yes, I am not friendly toward "pro designers" who come here asking for free help. Sorry.

    Since the Codex is a community effort you are more than welcome to contribute and help to make it "clearly written" :)

  8. tsguitar
    Member
    Posted 6 years ago #

    That's what I mean. You don't have permalinks enabled at all, that's why you're having to type in addresses as you do.

    The irony, in light of your response saying that you did some research on all this, is that this should have been the first thing you tried: enabling permalinks to see what the result is. How do you know it's broken if you never even tried it out? That makes it look like you didn't give anything a shot at all. Experiment on your own while you're waiting for others to reply. That makes everyone aware that you, too, are doing your best to solve your problem.

    P.S. Can we focus to get this issue resolved? Everything else needs to take a back seat.

  9. NixDesign
    Member
    Posted 6 years ago #

    Right - this is what has been happening those other times it crashed too - it's just crashed again!

    As soon as I change anything in that permalink page (this time I simply selected the second option for date based permalinks - note I have deleted all reference to dates and times in the template code), I get a 500 Internal Server Error.

    Nothing on my dashboard works, everything is kaput!

    I then have to go and delete WP, create a new database with a new username and password, change the wp-config file to reflect those changes and upload WP again, add in all the template files etc and try something else.

    This is really driving me nuts.

    When I say I'm deleting all reference to page title, date etc, in the templates as I don't need that information at the top or bottom of each page because it's not a blog - it's a static site. Is that the problem?

  10. NixDesign
    Member
    Posted 6 years ago #

    Moshu, I have $400 in the bank. I am learning WP to hopefully make my job easier and be able to attract clients by offering a website with a CMS as that's what they want these days.

    I am not being paid to learn this stuff.

  11. tsguitar
    Member
    Posted 6 years ago #

    A quick search for 500 errors:
    http://www.checkupdown.com/status/E500.html

    Sounds like your hosting company has troubles. Time to hit the Codex again (if you're going to be dealing with WordPress, you're going to have to learn to read it and make sense of it):
    http://codex.wordpress.org/Using_Permalinks

    mod_rewrite permalinks require Apache's mod_rewrite module; people running WordPress on other server environments cannot use them.

    I'm thinking that your server doesn't have mod_rewrite on. Who is your hosting company?

  12. NixDesign
    Member
    Posted 6 years ago #

    My hosting company is Haven Hosting.

    I have checked with them and have a 12 page print out on what their server runs and has enabled.

    Under the heading "Apache" and "Loaded Modules" it has a list of about 40, one of which is mod_rewrite.

    I also have a .htaccess file in my /blog directory and one in the root directory of my site.

    Both are supposedly empty though, could this be the problem?

  13. moshu
    Member
    Posted 6 years ago #

    XAMPP is free: http://www.apachefriends.org/en/xampp.html
    just install it on your computer and you can play with WP locally - no need to experiment on the server, and any change to any file is instantly visible.
    Guide: http://www.tamba2.org.uk/wordpress/xampp/

    EDIT. I see now that the server has the req's for permalinks. Maybe you should read again the part of the instructions that says to make the file writable...

  14. NixDesign
    Member
    Posted 6 years ago #

    Moshu, thanks for those links, I'll take a look at them. I have posted questions here also about file permissions previously y'now, as I figured that might be the problem before. I now have them set to 776 because that seems to be the minimum that my host allows.

    Thanks for that 500 error link too TSGuitar.

  15. moshu
    Member
    Posted 6 years ago #

    For files to be writable it has to be 666.
    However, if the htaccess file is not writable by WP - it should display for you the code that is supposed to be copy/pasted into the file.
    So, it either writes the code into the .htaccess or it shows it to you.
    There is no third option. (actually, there is: bad host)

  16. NixDesign
    Member
    Posted 6 years ago #

    The .htaccess file is now set at 776 because when it was set at 666 WP didn't write the code automatically to the .htaccess file, it displayed it for me to write to that file. I did that and uploaded the .htaccess file again and WP crashed just as it has again this morning.

  17. NixDesign
    Member
    Posted 6 years ago #

    Okay, I can see using cPanel that WP has written the code to my .htaccess file.

    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]# BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    I'll call my host and report back.

  18. NixDesign
    Member
    Posted 6 years ago #

    Strange, but WP had written the permalink rules to the .htaccess file twice yet I was only seeing them once in cPanel?

    Still can't quite get page permalinks to work though, I'll keep trying.

    Thank you TSGuitar and thanks Moshu.

Topic Closed

This topic has been closed to new replies.

About this Topic