WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Permalink now working after installing WP 2.6 (28 posts)

  1. Saravanan07
    Member
    Posted 6 years ago #

    I have just installed WordPress 2.6 and a custom permalink is not working. Only the default permalink able to display all the post and the pages. Hope someone could help me to resolve this problem. Thank you.

  2. 7milesdown
    Member
    Posted 6 years ago #

    I got the same problem. Seems to be an issue with my Windows server however it was working with index.php/mypost when I was running 2.5.1 this really sucks!!!

  3. acheashadow
    Member
    Posted 6 years ago #

    same problem as me!

  4. 7milesdown
    Member
    Posted 6 years ago #

    At least I know Im not the only one experiencing alot of problems. Seems like this release wasn't ready after all...

    Hopefully google doesn't remove all my hard earned permalinks till I can find a fix!!

  5. acheashadow
    Member
    Posted 6 years ago #

    If this doesnt get fixed soon googles gonna screw me!

  6. VelvetBlues.com
    Member
    Posted 6 years ago #

    Hmmm. This is troubling....

    For now, I'm only using 2.6 for new installs, until I understand all of the new differences.

    As for the permalink structure, did you delete your old .htaccess file and then rebuild a new one? If not, you might want to try that.

    Good luck with Google. :-)

  7. 7milesdown
    Member
    Posted 6 years ago #

    Im not using Apache. Im on a Windows server. Been running wordpress without any major problems with permalinks until now. Its been 4 years since I've used the software with a Windows host. I've tried several workarounds since upgrading to 2.6 without any success..

    I really wish WordPress thought about us Windows IIS Server users.

  8. acheashadow
    Member
    Posted 6 years ago #

    I tried deleting htacess and it didnt work :(

  9. 7milesdown
    Member
    Posted 6 years ago #

    seems like this was an issue they missed during the testing phase for windows users. It was a bug noticed ealier but unfortunately unfixed.

    http://wordpress.org/support/topic/187700?replies=10

  10. acheashadow
    Member
    Posted 6 years ago #

    Well its pretty much the same.. it works if i change the permalink structure to a default option but then I have the problem of all indexed google pages and ive worked far too hard to get top listings on google just to throw them all away.

  11. nickajordan
    Member
    Posted 6 years ago #

    I'm experiencing the same problem with Zeus web server on Linux. I hope this is going to be fixed soon as it's a major pain.

  12. 7milesdown
    Member
    Posted 6 years ago #

    did it work fine with 2.5.1? using index.php/yourpost

    If it is, then it has to be a bug in this update or a database change.

  13. Saravanan07
    Member
    Posted 6 years ago #

    I didn't delete the old htaccess file..somehow..its not workin..

  14. Greg Rickaby
    Member
    Posted 6 years ago #

    I'm hosted on Linux and Permalinks don't work either...don't feel bad Windows guys! Had to restore my 2.5.1.

    The bitch of it? They knew it didn't work: http://wordpress.org/support/topic/187700?replies=10

  15. Anonymous
    Unregistered
    Posted 6 years ago #

    I am running on a Mac and custom permalinks don't work either. The error is on the index.php/%postname% structure ; was already present in the 2.6 beta versions.

    PLEASE HELP US HERE!

  16. jinge
    Member
    Posted 6 years ago #

    Yes PLEASE HELP US - NOW!

  17. Peter Ould
    Member
    Posted 6 years ago #

    I had exactly the same problem (and the one with not being able to login - fixed that by deleting cookies).

    The permalink issue was solved by setting the permalinks back to default and then setting them again back to how I had them. Basically, you need to remind wordpress how you want them.

    Hope this helps.

    P+

  18. acheashadow
    Member
    Posted 6 years ago #

    I fixed it by going to a default and leaving it there all my old google listings just redivert - oh and im on linux

  19. 7milesdown
    Member
    Posted 6 years ago #

    Pould- I tried that but it didn't work for me on the windows server.

  20. geneome
    Member
    Posted 6 years ago #

    I fixed it on my end, so hopefully this might help someone. The short of it: I stopped using custom permalinks:

    My permalinks where set to a custom setting which looked like "index.php/%year%/%monthnum%/%day%/%postname%/" which I guess was set because I set the permalinks in a very old WordPress version. So seeing that the default method worked, I just used one of the pre-set permalink options (day and name in this case) instead of the custom (which it would seem is no longer recognized) and it all worked right again as well as even forwarding my links the were coded as "index.php/%year%/%monthnum%/%day%/%postname%/" to the new "%year%/%monthnum%/%day%/%postname%/" link.

  21. Saravanan07
    Member
    Posted 6 years ago #

    Hello..I have done a temporary fix for the problem. What you have to do is add some values in for the category and tag bases. The words "category" and "tag" will do just fine. As long as they are not blank, this should work around the bug.See the image:-

    http://farm4.static.flickr.com/3228/2672367868_276c738559_o.png

  22. Saravanan07
    Member
    Posted 6 years ago #

    Many people have reported permalinks not working after upgrading to 2.6. In all cases, these people have permalink structures that contain "index.php". This is a bug, detailed here: http://trac.wordpress.org/ticket/7306

  23. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    There's a sticky on this subject:
    http://wordpress.org/support/topic/189058

    @gregrickaby: Just because somebody makes a post doesn't mean we read it. He didn't post it anywhere else, including the bug tracker.

  24. Saravanan07
    Member
    Posted 6 years ago #

    Thx for the Help Otto42..;)

  25. Jon Griffith
    Member
    Posted 6 years ago #

    I see. So, is there going to be a fix for this? My site is completely useless as of now since none of the page links work, the comments don't work, etc., etc. It's all due to the permalink problem and I'm short of knowledge when it comes to "why" this happens. I can follow steps to fix if there are steps...

  26. Jon Griffith
    Member
    Posted 6 years ago #

    Hmmm...okay I added category and tag bases, but I have no idea what that actually does:

    Category: /categories/
    Tag: /tags/

    What will the effects of this be? It also appears that my comments have been restored too...guess that makes sense since everything is dependent upon the permalinks working.

  27. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The effects of it should be to fix the problem. Makes sense, no?

  28. thecoup
    Member
    Posted 5 years ago #

    Wow, this is terrible. My problem was a little different. The solution is below.

    On WP 2.6.1, the site worked initially with /%year%/%monthnum%/%postname%/. I have WP installed in /wordpress/. I kept the blog viewable at /wordpress as well for development. When I changed the blog address to the root using these directions, pretty permalinks stopped working. I switched it back to the /wordpress directory, without ever touching .htaccess and the pretty permalinks still didn't work!

    After trying many many things, the solution that worked for me:
    - dropped the www's from the wp and blog directory. this forced me to login again. put back the www's, and logged in again.
    - chmod .htaccess to 777
    - changed permalinks settings from default, to numeric, and then back to month and name. presto!
    - important: chmod .htaccess back to 644

    The weird thing: WP never had trouble changing the .htaccess file. I downloaded and checked that it was updated correctly. For some reason, things still wouldn't work as expected. The steps above are ridiculous, but they're what I did before things started working again...

Topic Closed

This topic has been closed to new replies.

About this Topic