WordPress.org

Ready to get started?Download WordPress

Forums

Custom Permalink messes up my "image uploader" (7 posts)

  1. justinthedesigner
    Member
    Posted 1 year ago #

    regarding - http://justinthedesigner.com/

    I recently purchased the "Yin & Yang: Clear - WP Portfolio Theme" theme from themeforest. I asked this question to the designer of the theme and they say it is a wordpress or hosting issue and I need to ask my question here.

    The theme has a portfolio section and in this section there are browse buttons that are used to upload images. When i have my permalinks set in default mode the browse buttons work fine. - But when i change my permalink settings to custom or anything other then the default permalinks then my browse button opens up and instead of displaying the uploader tool it shows my homepage with a 404 error code.

    I want to change my permalinks to postname or custom for SEO reasons as the default permalinks are ugly. But i cant get my theme to work with anything but the default. any ideas are much appreciated.

    - All my plugins were de-activated and this did not help.
    - the designer of the theme says its not a theme issue
    - my wordpress was installed using host-gator
    - my website is also hosted with hostgator

    justin
    [Email removed. URL only once is enough]

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Does your permalinks work with Twenty Twelve theme?

  3. justinthedesigner
    Member
    Posted 1 year ago #

    I dont know because the twenty twelve theme doesnt have that same kind of browse button.

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    No problem with the buttons. You can go back to your favorite buttons. But try and see if permalinks work, image uploads work, etc. when you are on Twenty Twelve theme.

  5. justinthedesigner
    Member
    Posted 1 year ago #

    I checked they do work. the regular image uploader works in the yin and yang theme as well but its the ( browse button that doesnt work for the portfolio)

  6. justinthedesigner
    Member
    Posted 1 year ago #

    this is a reply from the theme designer:

    3) I can definitely confirm that I have never seen this issue with any other customer utilizing the theme, and given that the "Yin & Yang" theme is among the top 15 best selling themes on ThemeForest of all time (sold in more than 5700 copies), that should be a significant proof that there is nothing wrong with the theme itself, as the uploader works on countless of different WordPress installations. Also, the regular uploader is not the same as the "thickbox" uploader, which is a standard feature in WordPress, utilized by the Yin & Yang theme for the selection of images (for more information on thickbox, please visit the following page: http://codex.wordpress.org/ThickBox). Having said all that, there is still a possibility that the issue is caused by a plugin, as an apparently inactive plugin can still cause problems. Therefore, please try removing your plugins from the /wp-content/plugins/ directory via FTP, to see if that will work for you.

  7. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Interestingly, the codex page cited by the theme designer says: "There is currently no text in this page".

Topic Closed

This topic has been closed to new replies.

About this Topic