WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Nav Menu Noindex (6 posts)

  1. stonedan
    Member
    Posted 1 year ago #

    Hi guys,

    I have a problem and can't seem to work it out.

    I have created a custom menu to use as my navigation, the problem is, they are set to noindex, dofollow. How can I make them so they are indexed and dofollow?

    The website is treatdoganxiety.com and it's the top navigation (under the header) I am having problems with. If I click on "dog training" for example, my nofollow chrome extension tells me the following -

    Meta-Robots NoFollow: false
    Meta-Robots NoIndex: true

    Any ideas how I can sort this out so its - Meta-Robots NoIndex: false ?

    Thanks for any help
    Dan

  2. Kevin Ashbridge
    Member
    Posted 1 year ago #

    What's the difference in how you've set up 'Dog Separation Anxiety' verses the other menu items. This one is indeed set to rel="index follow"

    The fix might be to install and SEO plugin, like WordPress SEO by Yoast, which has specific setting for the rel attributes.

  3. stonedan
    Member
    Posted 1 year ago #

    Hi Kevin,

    Thanks for the reply.

    There is no difference on how I have set up "Dog Separation Anxiety" verses the other menu items. I just used a custom menu. They are category pages but I wanted them at the top.

    I have WordPress SEO by yoast installed and have even selected the option in the category section to follow these pages but it has not worked.

    This is a tricky one I can't get my head around!

  4. Kevin Ashbridge
    Member
    Posted 1 year ago #

    Are the individual pages (posts) marked as

    Meta Robots Index: Index
    Meta Robots Follow: Follow

    rather than just the category? Something is different.

  5. stonedan
    Member
    Posted 1 year ago #

    Thanks for the reply again Kevin.

    I did not create any pages or posts, as you can see if you click dog aggression (I have not wrote an article yet with the category dog aggression).

    So I decided to create a page for dog training and have it set to index, follow via a wordpress plugin (WordPress Meta Robots) but this has seemed to not work either!

    Very confused. Any ideas?

    [ Please do not bump, that's not permitted here. ]

  6. stonedan
    Member
    Posted 1 year ago #

    For anyone interested, my meta robot plugin was causing the problem, maybe conflicting with the Yoast plugin, not sure, but it's sorted! :D

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.