WordPress.org

Ready to get started?Download WordPress

Forums

Custom Menu Causes Internal Server Error (8 posts)

  1. wsnider28
    Member
    Posted 2 years ago #

    If I use the default navigation menu on my site, everything works fine, but I don't want the default menu, I want to use a custom menu.

    My theme supports 1 custom menu, which I have created. When I try to enable that custom menu, I get an "Internal Server Error...Apache Server at mydomain.com Port 80"

    I've already tried:
    -disabling all plugins
    -reverting to the Twenty Ten theme
    -temporarily renaming the .htaccess file
    -taking all links and items out of the custom menu.
    -completely uninstalling WordPress, deleting the database and all files, then re-installing, rebuilding the site and the menu, and trying again.

    I first created this site on JustHost, and all worked well. The issue came when I restored the site on GoDaddy. Like I said, though, I've since completely deleted and started rebuilding with new files and a blank database. I'm using the site on JustHost as a template only. No files have been copied over from one host to the other.

    Of course GoDaddy says it's an issue with scripting in the WordPress files, which they don't support. Not sure if that's really the issue, but while I'm (still) on hold with GoDaddy, thought I'd post it here and see if anyone knows what might be going on.

    TIA

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Make sure you have chosen PHP 5+ in your account (WP 3.3.1 requires this) and if you provide a link to your site it may help us help you. Also, what is your Hosting Plan on GD?

  3. wsnider28
    Member
    Posted 2 years ago #

    Yep, using PHP 5.2

    Site is crashtesthobby.info, hosting is WordPress Economy

    ...however, I've done some more troubleshooting and found that if I disable the WooCommerce plugin, the custom menu works. The theme I'm using requires that plugin, so it was hard to find out. I had to switch themes first, see that it didn't work, then additionally disable WooCommerce, and see that it did.

    Obviously, I'm on the WooThemes forums as well, trying to resolve this.

  4. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    This hosting environment will prove most lacking, use a Linux 4GH setup at least. GO with ultimate, for a few bucks more a month you get much better 'stuff'. Or, use a different host.

  5. wsnider28
    Member
    Posted 2 years ago #

    GoDaddy's WP Economy already is a Linux 4GH setup. Going to ultimate would only get me more email accounts and databases... which I don't need.

    I'm really wary about completely switching hosts when I don't KNOW that the host is the problem.

    Thanks, though

  6. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Economy plans have more sites per server (IP)(twice as many) and you can only host one site per account. I have no such issues with many websites there, so whether they state so or not, don't expect your cheapest option to perform as well...as a commercial site, I would want my customers to have the best experience possible..

    Did you install WP or did you use the Hosting Connection?

  7. wsnider28
    Member
    Posted 2 years ago #

    For a website of this size, I've never had an issue with performance. Economy is fine for about 80% of people's websites. Of course you get more quality for paying more, but that's not the issue here at all.

    I was right, by the way. The issue was one with the WooCommerce plugin's coding. The WooTheme Ninjas were able to disable a setting that was causing the break in the site, and will be correcting the bug in their next version.

    In the rare chance someone else is having this issue here's what to know: If you are not offering a WooCommerce account login function for users, and you therefor delete the "My Account" page that was automatically created during the WC setup, you need to go to the WC settings, then the "Pages" tab. Make sure to UN-check the box labeled "Append a logout link to menus containing "My Account" "

  8. brianssinger
    Member
    Posted 1 year ago #

    BUMP --- Rare? This little issue is still going on. It took me hours to nail it down. All I can say as to why it was happening is to think it had everything to do with the custom menu's.

    For us, to reproduce the problem all one needs to do would be to try to apply your custom menu to any of the Theme Locations drop down lists which after install of woocommerce, will be blank.

    Because I searched for this answer for some time, some more info:

    Where it says Your theme supports 3 menus. Select which menu appears in each location. Or if it says Your theme supports 2 menus. Select which menu appears in each location, this reproduces the Internal Server Error page which becomes the default for your front end site.

    Event went so far to uninstall all woothemes, which was a shame. Not knowing that it was the WOOCOMMERCE integration which was to fail.

    -=-=-=-=-=-=-=-=-=-=-=-=-=
    Big thanks to the team at woo to share the temporary fix, however I found this is the ONLY place I could find the fix. After googling the FIX, there are still no other places I could easily find discussing the solution.

    Hence the -BUMP-

    Again:

    If you are not offering a WooCommerce account login function for users (as this was a site already using menus I am unclear on what it is), and you therefor delete the "My Account" page that was automatically created during the WC setup (quite sure we never did that on purpose)

    you need to go to the WC settings, then the "Pages" tab. Make sure to UN-check the box labeled "Append a logout link to menus containing "My Account"

    THANK YOU THANK YOU THANK YOU

Topic Closed

This topic has been closed to new replies.

About this Topic