WordPress.org

Ready to get started?Download WordPress

Forums

Easy Recipe
[resolved] Custom Labels - Localization Problem (6 posts)

  1. samhat
    Member
    Posted 1 year ago #

    Hello,

    If I update the custom labels with non-english chars, the labels are not saved correctly.

    For example for char "ı", you get "ılıÅ�ı" after saving.

    Thank you

    http://wordpress.org/extend/plugins/easyrecipe/

  2. samhat
    Member
    Posted 1 year ago #

    Another localization issue is times. You can't use mins in your language. You can update the times in html but next time when you want to update the recipe, you can't use the update button as it doesn't let you save.

  3. tomasSK
    Member
    Posted 1 year ago #

    This does only the last version 09, until 08 there weren't any problems with Custom Labels. I emailed John about this a couple of weeks ago but unfortunately there hasn't been any answer from him yet. I have a PRO version with a live support which always worked well for me but last 3 weeks my emails are just ignored. Why - I don't know.

    To change mins and hours in HTML should be always the last thing you do, after you are sure you won't need to update the recipe again. But I think this still works on my website. It only changes my language back to English mins and hours again, after I do some changes - which is pretty normal.

    John also promised a translation option some time ago - as nothing has happened I still use Custom Labels and change mins+hours in html like you do. I'm happy to wait but there is no answer from John so I don't know what is going on.

  4. tomasSK
    Member
    Posted 1 year ago #

    I have a fix for Custom Labels.
    1. go to wp-content/plugins/easyrecipe/lib OR wp-content/plugins/easyrecipeplus/lib
    2. open EasyRecipeSettings.php OR EasyRecipePlusSettings.php
    3. delete this:
    if (isset($settings[$key])) {
    //$this->settings[$key] = stripslashes(trim(wp_filter_nohtml_kses($settings[$key])));
    $this->settings[$key] = htmlentities(stripslashes(trim($settings[$key])));
    }
    4. replace it with:
    $this->settings[$key] = stripslashes(trim(wp_filter_nohtml_kses($settings[$key])));

    THIS WAS TESTED ON 2 DIFFERENT COMPUTERS WITH BOTH EASYRECIPE AND EASYRECIPEPLUS VERSIONS - it doesn't mess Custom Labels any more.

  5. samhat
    Member
    Posted 1 year ago #

    tomasSK: Thanks a lot for your response. I made the change, and now it works. You can live with the minutes issue but this was making it not possible to use easyrecipe plugin at all.

  6. Jayce53
    Member
    Plugin Author

    Posted 1 year ago #

    This has been fixed in the latest update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic