WordPress.org

Ready to get started?Download WordPress

Forums

Custom fields very buggy: Something strange happened. Try refreshing the page. (9 posts)

  1. Flamini
    Member
    Posted 6 years ago #

    Hi there I am having a major problem with 'custom fields'. The problem was there with 2.3.1 and just upgraded to the latest build and the problem is still there.

    The problem arises when I go into an already published post and edit. I need to add a custom field so I click the button to add custom field, I then get this error: Something strange happened. Try refreshing the page.

    I have turned every plugin off but still I get this error.

    Is there a fix for this? I need my custom fields.

    Any ideas or fixes?

    Thanks

  2. MichaelH
    Member
    Posted 6 years ago #

    I just tried that on a 2.3.1 blog and a 2.3.2 blog and didn't experience the problem.

    Does the problem happen when all plugins are deactivated?

    Maybe clear your browser and cache or try from another computer. When you upgraded to 2.3.2 did you disactivate all plugins first? Did you and remove and upload the WordPress files as suggested in Steps 7 and 8 of Upgrading WordPress Extended when you did the upgrade?

  3. Flamini
    Member
    Posted 6 years ago #

    Yes it also happens when plugins are deactivated. I cleared cache and also removed and uploaded the WordPress files as suggested in Steps 7 and 8 of Upgrading WordPress Extended

    I need to point out this only happens when I need to add a custom field to an existing post (ie. only when I edit a post), when I add fields to new posts all is good.

    Any further thoughts?

    Thank you

  4. Flamini
    Member
    Posted 6 years ago #

    I just done a fresh install and upgraded the db but this error 'Something strange happened. Try refreshing the page' still comes up. The error shows in IE & Firefox.

    Any ideas?

    Thanks

  5. MichaelH
    Member
    Posted 6 years ago #

    Here's an explanation of the 'Something strange happened' message:
    http://wordpress.org/support/topic/102221?replies=5#post-506651

  6. sweetsamara
    Member
    Posted 6 years ago #

    Well since it seems the moderators pretty much suck on helping anyone with this issue I took it upon myself to figure this out.

    If you are editing a post first change the post's status to unpublished or "draft" then click save and continue editing. The custom field should now work.

    Hope this helps everyone who's having this problem.

  7. whooami
    Member
    Posted 6 years ago #

    Well since it seems the moderators pretty much suck on helping anyone with this issue I took it upon myself to figure this out.

    lol, nice one. too bad the moderators dont exist to help you.

  8. Tzaddi
    Member
    Posted 6 years ago #

    I've seen this error when a user tried to enter the value into the key field.

    e.g., they selected the custom field from the drop down menu, then in the next (middle) input field they entered the value they wanted to assign to the custom field. But, that input field is meant for creating new custom field names.

    It would be nice if the error message were more specific in this case.

  9. ezerick
    Member
    Posted 6 years ago #

    See http://wordpress.org/support/topic/154424 for my reply on this issue

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.